DOI retrieval not working anymore


#1

Hi everyone,

until recently, my JabRef was always able to retrieve bibliographical information about books and articles by DOI. These last days, it did not work anymore. I first thought it was a problem with the specific DOIs I provided (in that there is no inforrmation about them in the database), but I got suspicious and I have now seen that even for entries I am completely sure I created using the DOI-based information, JabRef cannot obtain any info anymore.

What could be a reason for this behaviour? I am running JabRef 3.8.2 on Win 10.


(Tobias Diez) #2

Crossref changed a few things on there side which broke the DOI feature. It should work again in the most recent development version. But please be aware that this version is still in a pre-release state and some things might not work as expected (so in particular make a backup of your database).


#3

Thank you a lot for your reply, that is very helpful information. This means that a safe DOI feature will in all likelihood again be included in the next release version?


(Tobias Diez) #4

Yes, of course, we are committed to keep the DOI / Crossref support. Hopefully, the new version will be released in around a month.


(Jan Coenen) #5

Hi there , new development version gets part of it back … but then freezes jabber completely, thus still not usable…


(Tobias Diez) #6

@Jan_Coenen can you please report any issues you have with the most recent development version at https://github.com/JabRef/jabref/issues. Thanks!