Entry Editor extremely slow with shared database (remote MySQL)



Hi all,

we recently had to switch to a remote MySQL server that is accessed via a SSH tunnel with port forwarding. When using this database connection, the Entry Editor is extremely slow (practically unusable). Files and local MySQL server are working OK, by the way. I tried turning off autocompletion in the preferences, but that didn’t help.

Although it seems to be common for SSH tunnel configurations to show higher latency, the database connection does not seem overly laggy, at least it is responsive on the mysql command line. However, JabRef seems to do a lot of (unnecessary?) database queries while editing entries.

Any ideas how this can be fixed? Are there any configuration options we could try to minimise the lag?


(Christoph) #2


did you try the latest master version?

There were some changes so that the entry editor does not always fire up after every typed char.



Yes, I tried the latest master version. Same problem.


(Christoph) #4


thats not good. Would you please open an issue with all necessary information here?

Then we can track that error and see if someone can look into that


OK, I’ve done that, thanks. Issue 3736