Error invoking JabRef-4.x


(Rich Shepard) #1

I’m configuring a new desktop running Slackware-14.2/x86_64. The jdks
available are openjdk-8u171_b11 and openjdk7-7u181_b01. This is the result
when I try to load the application:

]$ java -jar JabRef-4.3.1.jar Exception in thread “main” java.lang.UnsupportedClassVersionError: org/jabref/JabRefMain :
Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:808)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
at java.lang.ClassLoader.loadClass(ClassLoader.java:430)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:323)
at java.lang.ClassLoader.loadClass(ClassLoader.java:363)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

What might be causing this?

Rich


(Tobias Diez) #2

This looks like a bug to me. Can you please report it at https://github.com/JabRef/jabref/issues


(Rich Shepard) #3

Tobias,

Done.

Regards,

Rich