Pasting DOI numbers


(Birgit Kellner) #1

I’m using Jabref 4.1 on Ubuntu 18.04. I noticed that when I paste DOI numbers, Jabref automatically creates a new entry with the retrieved data. Can I disable this feature, or use it selectively? Haven’t found anything in the settings.

I’m working on a historically grown bibtex-file and would like to manually add doi numbers to some entries just by pasting them into the form. But this does not seem to be possible. Ctrl-V automatically creates a new entry. Since my old entries are heavily annotated (local file links, manual keywords), replacing old entries by newly autogenerated ones isn’t an option.

Thanks in advance,


(Christoph) #2

Hi,

the automatic entry should only be created when you paste it on the maintable.
If you directly paste the number into the corresponding field in the entry editor it should work without problems.

I never had any problems with that.

Regards
Christoph


(Birgit Kellner) #3

The problem did exist with version 4.1 even when pasting the number into a field, or into the bibtex source code, but I now updated to 4.3.1 (should have tried this before, sorry), and the problem no longer exists. Thanks!