The timestamp field automatically updated; how to change it?


(Bernhard Kleine) #1

I noticed that while editing an entry the timestamp of that entry is updated. This is an undesired feature for me, but in JabRef 5.0-dev–snapshot–2018-10-02–master–0b45ab51c I cannot stop it. In preferences-General the field “update timestamp on modification” is checked , but greyed out and not changeable. What do you propose where change this behaviour?

Regards
Bernhard


(Christoph) #2

Hi,

the preference ch is dependent on another option.
You first have to check “Mark new entries with addtional date” and then you can check/uncheck the option “Update timestamp on modificaiton”


(Bernhard Kleine) #3

Hi,
“Mark new entries with additional date” has been checked. And the “Update timestamp on modification” was greyed out. That is somewhat fishy: When the first is checked than the second should be to check or to uncheck. That this was not possible, is not understandable and may be a bug. it is at least not easy to grasp. grafik


(Bernhard Kleine) #4

There is definitely a bug:
grafik

I have the timestamp field unchecked as you can see. However saving the options, closing Jabref and open it again, the timestamp field is checked again.

This is with the dev version of today. Do you raise the bug or shall I do it?
Bernhard


(Christoph) #5

Please file a bug and add the screenshots and steps.

Agree with you, that looks odd.