Cannot send email


I am using JabRef 5.5 in Ubuntu 21.10.
I would like to send one reference (and its pdf) by email, but it results in error creating email. I am not sure if this is an issue or something not well configured. Can anybody help?
The error I get is:
2022-04-13 11:53:18 [JavaFX Application Thread] org.jabref.gui.SendAsEMailAction.lambda$execute$0()
WARN: Error creating email: java.lang.UnsupportedOperationException: The MAIL action is not supported on the current platform!
at java.desktop/java.awt.Desktop.checkActionSupport(Unknown Source)
at java.desktop/java.awt.Desktop.mail(Unknown Source)
at org.jabref@5.5.60000/org.jabref.gui.SendAsEMailAction.sendEmail(Unknown Source)
at org.jabref@5.5.60000/org.jabref.gui.util.BackgroundTask$ Source)
at org.jabref@5.5.60000/org.jabref.gui.util.DefaultTaskExecutor$ Source)
at org.jabref.merged.module@5.5.60000/javafx.concurrent.Task$ Source)
at java.base/ Source)
at java.base/java.util.concurrent.Executors$ Source)
at java.base/ Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
at java.base/ Source)
2022-04-13 11:53:18 [JavaFX Application Thread] org.jabref.gui.JabRefDialogService.notify()
INFO: Error creating email

Cannot reproduce this on

JabRef 5.6–2022-04-11–1c782b7
Windows 10 10.0 amd64
Java 17.0.2
JavaFX 18+12

Cannot reproduce using the .deb version of JabRef 5.5
on Linux Mint 20.3 (Ubuntu based. Uses kernel 5.4).
Clicking the button opened my e-mail program (Thunderbird) automatically. No error message.

I had installed the portable version for linux.
I have tried now with the deb version, but still the same problem.

@t-morales This seems to be some java issue, I read that you may need libgnome-2 to get it working
the thread is about another function of java.awt.Desktop, but it’s the same class, so this might be workin here

Maybe you are right and it is related to that. I am actually using Kubuntu 21.10 with KDE plasma.
Unfortunately that post is rather old and libgnome-2 is no longer available.
Has anyone with KDE got to use this function?