Convert timestamp to creationdate in 5.3

I just downloaded 5.3 and wanted to upgrade my timestamp fields. I always had it enabled so that on import it would write to that timestamp field, hence I would like to run Tools → Cleanup Entries and enabled ‘Convert timestamp field to field creationdate’.
But unfortunately, it does nothing.
I selected all my entries, but the cleanup says “no entries to clean up”.
If I look into my bib file, I can still see the timestamp fields.

I was able to replace that field in vim though using this pattern:
:%s/^\s\+timestamp\s\+=\s\+{\(\d\+-\d\+-\d\+\) \(\d\+:\d\+\)},/creationdate = {\1T\2:00},/

Not sure if this is a bug or if I’m holding it wrong…

btw, thanks for this great feature!


as far as I remember this is implemented as a migration which runs on startup of the new version.
Maybe @DominikVoigt can add some more details


ah okay, maybe I know then what the issue is: I opened up 5.3 and my library was already opened. I noticed that after first starting with 5.3, it did some re-formatting of the file already (I have the changes in git).
However, only then I enabled the new features (both creationdate and modifieddate).

Maybe the issue is that this automatic conversion only works if you have enabled the features and then load the file.
However I do not understand why cleanup files does nothing then?