Freeze/Slow performance when adding a new entry for shared DB

Hi all,

Jabref version: 5.13–2024-04-01–6bdcf63

I am managing a relatively large literature set (24K entries, a large amount with source PDF). Within our group we share this on a newly created SQL database.

When I want to add a new item into our database, jabref freezes. It takes up to 10 minutes for the “add new entry” window to open, during which the program is not responding. After looking through the different forums I have tried to improve/troubleshoot this using the various settings, however to no avail.

The database itself is not the bottleneck.

Does anyone here have a suggestion what I could try next?



Unfortunately, this is a kind of known issue. I already took a more in-depth look at it some time ago and tried to improve this (do not run expensive operations on the UI Thread); however, that turned out to have some other unwanted side effects… Maybe I find some time to take another look at this issue.
Any help would be appreciated.