Jabref always displaying full screen on Ubuntu, not in Gnome windown

On my machine Jabref always fills all the screen and does not appear within a window. The windows created by menu items of Jabref (e.g. About JabRef) are created but not displayed and cannot be taken from “behind” the main JabRef window.
This behavior is not seen with the snap version of JabRef distributed for Ubuntu but this snap version does not interact well with LibreOffice writer, which I need.
May be something is wrong with the set up of my machine but I cannot find what.
Thank you for any help.
AMD Ryzen 7, Ubuntu 22.04, GNOME 42.9, X11
JabRef installed with dpkg from jabref_5.11_amd64.deb


this sounds weird. Can you test the latest development version from here? We recently upgraded the javafx version as well, maybe that is already fixed there.

Remember to make a backup of your library before trying out the new version

Thanks for your reply.
I installed version 5.12.174 (with sudo dpkg -i). It crashes without displaying anything on the screen
with the following the error message:
java.lang.IllegalArgumentException: Directory does not exist: /modules/org.jabref/journals [2.2.224/0]
(JabRef was launched manually with the command :/opt/jabref/bin/JabRef)
Indeed I cannot find this directory in /modules/.
Thank you.

Try starting JabRef from JabRef/lib/runtime/bin/JabRef .

Hi,Christoph, thanks for the suggestion.
I do not have the path “JabRef/lib/runtime/bin/JabRef” .
So I tried to launch Jabref 5.12.174 from :
and got exactly the same error about the missing directory:
Directory does not exist: /modules/org.jabref/journals [2.2.224/0]

I have no problem if I install JabRef directly from the Ubuntu repository with apt
(but this is JabRef 3.8.2 !).
Thank you.

Hi, the issue with the latest development not running has been solved. Can you please re-download it?

The new version of Jabref 5.12 runs OK on my machine and is now nicely displayed inside a window which can be moved and resized. Thank you very much for your help.


I just downloaded the version from JabRef download latest version and am experiencing very similar problems as decribed here (only full-screen, menus does not work with mouse). I’m on Ubuntu 22.04.4 LTS, GNome 42.9, Wayland. Did I download the ‘new’ 5.12 referenced to in this entry? How to investigate/workaround this problem? The current jabref snap has exactly the same problem for me.

update: same issue with 5.13. At least I can display the about window:
JabRef 5.13–2024-03-20–82a0338
Linux 5.15.0-100-generic amd64
Java 21.0.2
JavaFX 22+30