Jabref with Fedora 27

I am trying to use Jabref 4.1 under fedora 27. I downloaded and I am using the jar file. However when launching it I get the frame of the Jabref window completely empty (no buttons, menus, nothing).
In the command line I get:
“[AWT-EventQueue-0] WARN org.jabref.JabRefGUI - There seem to be problems with OpenJDK and the default GTK Look&Feel. Using Metal L&F instead. Change to another L&F with caution.
File: grouptree.fxml not found, attempting with camel case
File: grouptree.css not found, attempting with camel case”
The same while using the development snapshot.

As far as I understand this should be a solved issue in version 4.x. So I am probably doing something wrong. Any suggestions would be greatly appreciated.




could you please verify that you are using the latest java 8 version? ( I think the most current is 8u161))
Run java -version in the terminal to display the version

This is the output of the command java -version:

openjdk version “1.8.0_161”
OpenJDK Runtime Environment (build 1.8.0_161-b14)
OpenJDK 64-Bit Server VM (build 25.161-b14, mixed mode)

What is strange is that it was working up to a certain point, but I can not remember exactly what happened when it stopped working.



It looks like you have selected a look and feel that does not work on your system. You may try to reset the preferences using java -jar JabRef.jar -d all from the terminal.

It did not work. Also I do not recall changing the look and feel from jabref settings.
I also deleted the .java folder in my home directory, but it did not change the outcome. Any other place where I could find (and delete) settings?
Thanks a lot

Ok, that is strange. To be honest, I’ve no clue about the source of the issue you experience. I guess that your java installation got corrupt or misconfigured. Do other java-based application work as expected?

You may also try out the build from https://builds.jabref.org/maintable-beta, which is a complete rewrite of the main user interface using modern technologies. Maybe this version works for you. But be warned that this build is in an early development stage and may still have some rough edges (see https://github.com/JabRef/jabref/pull/3621 for an overview of known bugs).

The other java applications do not seem to have big problems. I will try also to reinstall java and to build the new version.
Thanks a lot


I am having the same problem. using Fedora 27,
openjdk version “1.8.0_162”
OpenJDK Runtime Environment (build 1.8.0_162-b12)
OpenJDK 64-Bit Server VM (build 25.162-b12, mixed mode)

The problem occurs for JabRef-4.0, 4.1 and 4.2 master, it works fine with JabRef 3.8.2.
I am getting the same warning about Look&Feel and the window is empty. However, if I wait long enough (5 minutes or so) it eventually loads fine. I guess JabRef is just VERY slow.

I also tried to load other L&F in Preferences->Appearance, but I get some error messages that JabRef cannot find the files:

12:50:05.697 [pool-3-thread-2] ERROR org.jabref.logic.util.io.CiteKeyBasedFileFinder - Problem in finding files
java.nio.file.NoSuchFileException: /scratch/home/***/JabRef
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86) ~[?:1.8.0_162]
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:1.8.0_162]
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:1.8.0_162]
at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55) ~[?:1.8.0_162]
at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144) ~[?:1.8.0_162]
at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99) ~[?:1.8.0_162]
at java.nio.file.Files.readAttributes(Files.java:1737) ~[?:1.8.0_162]
at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:219) ~[?:1.8.0_162]
at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276) ~[?:1.8.0_162]
at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322) ~[?:1.8.0_162]
at java.nio.file.FileTreeIterator.(FileTreeIterator.java:72) ~[?:1.8.0_162]
at java.nio.file.Files.find(Files.java:3687) ~[?:1.8.0_162]
at org.jabref.logic.util.io.CiteKeyBasedFileFinder.findFilesByExtension(CiteKeyBasedFileFinder.java:91) ~[JabRef-4.0.jar:?]
at org.jabref.logic.util.io.CiteKeyBasedFileFinder.findAssociatedFiles(CiteKeyBasedFileFinder.java:42) ~[JabRef-4.0.jar:?]
at org.jabref.logic.util.io.FileFinder.findAssociatedFiles(FileFinder.java:23) ~[JabRef-4.0.jar:?]
at org.jabref.gui.fieldeditors.LinkedFilesEditorViewModel.findAssociatedNotLinkedFiles(LinkedFilesEditorViewModel.java:165) ~[JabRef-4.0.jar:?]
at org.jabref.gui.fieldeditors.LinkedFilesEditorViewModel.lambda$bindToEntry$3(LinkedFilesEditorViewModel.java:150) ~[JabRef-4.0.jar:?]
at org.jabref.gui.util.BackgroundTask.call(BackgroundTask.java:63) [JabRef-4.0.jar:?]
at org.jabref.gui.util.DefaultTaskExecutor$1.call(DefaultTaskExecutor.java:63) [JabRef-4.0.jar:?]
at javafx.concurrent.Task$TaskCallable.call(Task.java:1423) [jfxrt.jar:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_162]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_162]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_162]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_162]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_162]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_162]


the error which occurs should not be related to the Style option. It indicates that there might be sth wrong with your file directory settings. Please check your directory settings in the library tab and or in the Options

Oh sorry, that is true. I fixed that part. But there is still the same issue that we discuss here.
Now when I start JabRef I get the following output:

10:41:43.025 [AWT-EventQueue-0] INFO  org.jabref.logic.importer.OpenDatabase - Opening: ***/NewDatabase.bib
File: grouptree.fxml not found, attempting with camel case
File: grouptree.css not found, attempting with camel case

(java:4146): Gdk-WARNING **: gdkproperty-x11.c:325 invalid X atom: 367

JabRef opens a bit slow, but fine. However, when I double click on one line in the database to see the preview, the preview window stays empty for about 5 minutes, and I get the following output in the terminal:

10:44:36.730 [JavaFX Application Thread] ERROR org.jabref.FallbackExceptionHandler - Uncaught exception occurred in Thread[JavaFX Application Thread,5,main]
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@5f0facbe rejected from java.util.concurrent.ThreadPoolExecutor@1543ef6[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 1]
	at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(ThreadPoolExecutor.java:2063) ~[?:1.8.0_162]
	at java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:830) ~[?:1.8.0_162]
	at java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1379) ~[?:1.8.0_162]
	at java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:112) ~[?:1.8.0_162]
	at org.jabref.gui.util.DefaultTaskExecutor.execute(DefaultTaskExecutor.java:45) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.fieldeditors.LinkedFilesEditorViewModel.bindToEntry(LinkedFilesEditorViewModel.java:152) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.fieldeditors.LinkedFilesEditor.bindToEntry(LinkedFilesEditor.java:201) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.entryeditor.FieldsEditorTab.setupPanel(FieldsEditorTab.java:118) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.entryeditor.FieldsEditorTab.<init>(FieldsEditorTab.java:64) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.entryeditor.EntryEditor.addTabs(EntryEditor.java:342) ~[JabRef-4.0.jar:?]
	at org.jabref.gui.entryeditor.EntryEditor.lambda$new$0(EntryEditor.java:209) ~[JabRef-4.0.jar:?]
	at com.sun.javafx.application.PlatformImpl.lambda$null$5(PlatformImpl.java:295) ~[jfxrt.jar:?]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_162]
	at com.sun.javafx.application.PlatformImpl.lambda$runLater$6(PlatformImpl.java:294) ~[jfxrt.jar:?]
	at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95) ~[jfxrt.jar:?]
	at com.sun.glass.ui.gtk.GtkApplication._runLoop(Native Method) ~[jfxrt.jar:?]
	at com.sun.glass.ui.gtk.GtkApplication.lambda$null$5(GtkApplication.java:139) ~[jfxrt.jar:?]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_162]

I guess, it is something with JavaFX!?

Afterwards, when it finally loads the details in the preview window, I try to set a file link, i.e. download the pdf file for this entry, I get the same error in the terminal and nothing happens (at least for 10 minutes).


you could try changing the Look & Feel in the Options -> Apperance to another one. We had issues with GTK Look and Feel which might explain your problems

Changing Look & Feel does not help with the entry editor issue. The preview is just fine and opens immediately, but if I double click on one entry it takes approx. 5 minutes to open the entry editor. Once it opened, if I click on any tab in the entry editor the same, again it takes about 5 minutes to open the tab. No output in the console, no CPU usage, constant memory usage of about 400 MB.

I updated both java and Jabref and the problem persists.

java version “1.8.0_171” (tried both openjdk and oracle)
Fedora 27

java -jar JabRef-4.2.jar & [2] 8557 12:40:08.319 [AWT-EventQueue-0] INFO org.jabref.logic.importer.OpenDatabase - Opening: /home/jneumann/Programs/latex/NewDatabase.bib
File: grouptree.fxml not found, attempting with camel case
File: grouptree.css not found, attempting with camel case