Which version of openjdk and openjfx for JabRef 4?

I use JabRef (Version 4.3.1) under Ubuntu (18.04 back when I it worked), but the last time I tried to launch it, I got this error:

Error: Could not find or load main class org.jabref.JabRefMain

After some research, I think the problem might has to do with OpenJFX and the upgrade to Ubuntu 18.10.

According to this post "JabRef explicit requires JDK8 and openjfx8 ".

18.10 comes with openjfx 11+26-4. I figured out how to install openjfx8 manually by downloading and running the .deb file from https://packages.ubuntu.com.
But I still get the same error.

These are my currently installed versions:

$ java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-0ubuntu0.18.10.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

$ apt-show-versions openjfx
openjfx:amd64/cosmic 8u161-b12-1ubuntu2 upgradeable to 11+26-4
openjfx:i386 not installed

I read on another post that openjdk and openjfx needs to match (8u191 <-> 8u161).

What exact version of openjdk and openjfx do I need? And how can I install it?

HI, you are right, JabRef still requires Java 8.
I have no idea if the version of openjfx and openjdk must match, but you probably need to set it as default. No idea.
sudo update-alternatives --config java

The easiest way is to install the oracle java 8 from the ppa:

The installation instructions (still valid):

Thank you,

I had version 11 removed and only version 8 installed.

I will go with Oracle Java for now (that works for me) and switch back at a later point.

1 Like

We are currently in the progress of making JabRef compatible with java 9 and greater, but this is a more complicated process which also affects our used libraries. Any help is welcome,