Connection to OO finds more than one OO executable


#1

Hi there,
I’m trying to connect Jabref 32bit Win7 to my OpenOffice. With auto connect I get the error message “Found more than one OpenOffice/LibreOffice executable. Please choose one to connect to:”
both options refer to the same folder: C:\Program Files (x86)\OpenOffice 4
Uninstalled and reinstalled both OO and Jabref and Java. Manual connect set to the above mentioned folder doesn’t connect to my opened OO witer .odt docs.
Running out of options, anyone an idea?


(Christoph) #2

Hi,

have you tried the latest version of JabRef? There was an issue with the OpenOffice preferences.
If it does not help, I recommend trying to reset the preferences or you might have to manually adjust the preferences as outined here:

Regards


#3

Have no problem with connectivity when I downgrade to Jabref 4.1 and AOO 4.1.4, so at least I’ve got it working again. Lose connectivity when upgrading to anything above 4.1, eventhough I preserve the 4.1 settings.
Connectivity settings are:
entry key=“ooJarsPath” value=“C:\Program Files (x86)\OpenOffice 4\program\classes”/
entry key=“ooExecutablePath” value=“C:\Program Files (x86)\OpenOffice 4\program\soffice.exe”/
entry key=“ooPath” value=“C:\Program Files (x86)\OpenOffice 4”/

For instance in Jabref 4.2 after a loooong conectivity try I get the error message;
“Could not connect to running OpenOffice/LibreOffice. Make sure you have installed OO with Java support. If connecting manually, please verify program and library paths. Error message: null”

JabRef 4.2
Windows 7 6.1 x86
Java 1.8.0_172


#4

After installing Jabref 4.3.1 and resetting the preferences I get my original error as Jabrefs default dir to look for OO executables is C:\Program Files\LibreOffice 5 changing this to the correct OpenOffice dir doesn’t resolve the connectivity problem. Any other ideas?


(Christoph) #5

I have not really an idea, but it could be related that we integrate the libreoffice uno jars which are no longer compatible with the ones from OpenOffice.


#6

Thanks for your reply. Indeed, changing to LibreOffice did the trick!