Failure to connect to LibreOffice

Hello,

I cannot connect to Libreoffice (have tried several versions). Click on the “connect”-button opens the window seen in the attached screenshot. Connecting manually does not work either: My LO-versions are grey in the list of applications so I cannot choose them.

I would be very grateful for your help. Thanks.

1 Like

Hello Christian, JabRef needs to know the location of your OpenOffice executable (soffice.exe on Windows, and soffice on other platforms), and the directory where several OpenOffice jar files reside. If you connect by clicking the Connect button, JabRef will try to automatically determine these locations. If this does not work, you need to connect using the Manual connect button, which will open a window asking you for the needed locations.

Source: OpenOffice/LibreOffice integration | v5 | JabRef

1 Like

Thank you very much so far. I have tried to connect manually as well. A list of folders opens but I cannot find LO in those. (Indeed, whithin “Applications” of that list, only one subfolder can be found.)

1 Like

Have you tried searching for soffice with the search feature of your operating system? Does it find it?

Thanks, yes, I can find 3 folders. They are located within Application Support => OpenOffice.org

Hi,

first of all LO must be running and you should have a writer document open.
In the Manual connect dialog, press cmd + shift + g and enter the following path:

/Applications/LibreOffice.app/Contents/MacOS/soffice

tested with LO 24.2.3 (previous LO versions worked as well)

2 Likes

Hi there!
Good question.
I personally do not work with ms-office. However, I wrote a doctoral dissertation (3 years, 550 pages, master document) with LO, and I asked various colleges who were using ms-office or were familiar with both. It does not seem clear that one is better than the other.
Regarding LO though, I find that it crashes quite often. It seems that no more than 3 documents of 30+ pages should be open at a time.

1 Like