Broken KeywordDelimiter Preference permits start of JabRef

I used JabRef 3.6 without problem on Windows7. I am trying to download 3.6 release and jabref do’nt start. Fist I’ve seen that Java release was not OK and I 've downloaded last Java 8 release 111. I’ve try to uninstall JabRef 3.6 and install again 3.7 whithout succès.
Jabref error file is as follow :
Exception in thread “AWT-EventQueue-0” java.lang.StringIndexOutOfBoundsException: String index out of range: 0
at java.lang.String.charAt(Unknown Source)
at net.sf.jabref.preferences.JabRefPreferences.getKeywordDelimiter(
at net.sf.jabref.preferences.JabRefPreferences.getImportFormatPreferences(
at net.sf.jabref.JabRefMain.start(
at net.sf.jabref.JabRefMain.lambda$main$0(
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at Source)

I have tried on another PC and it’s OK
An idea about this problem please.
Thank you for your help

Hi @domjac!
Sorry for the late reply.
There seem to be some problems with your preferences.
You can try to reset the single preference entry regarding the keyword delimiter. Do you know how to start the JabRef jar-File from the command line? If yes, just append the parameter -d groupKeywordSeparator so the call would like this: java -jar JabRef-3.6.jar -d groupKeywordSeparator

If you don’t know how to start the jar file I can provide you a more detailed description.

Hi Matthias,
Thank you very much for your answer because I’m very interested in new Jabref functionalities.
I’ve tried to install Jabref 3.8 with the same problem.
Sorry, I am not a computer specialist and I don’t know how to start Jabref jar-file.
Do I have to do that before install release version?
Thank you, if possible, to send me more details,
Have a good day,

Okay, the easiest approach I think would be to create a new text file with this content:

"group/Keyword/Separator"=", "

Save this file as jabref.reg and try to open it with a double click.

Note: Windows will probably warn you before execution this file. It should not do any harm (just adding the value “group/Keyword/Separator”="," to your registry) - but I can not guarantee this.

After executing this fix JabRef will hopefully startup again.

Hi Matthias,
Sorry, but it doesn’t work.
I have an error message ( translated from French) "impossible to import …\jabref.reg : Specified file is not a script register.
You can only import binary script register from registry editor"
Do you have an idea?
Thank you it’s not easy to diagnose problems remotely.
Have a good day,

Ahh I see… there must be an additional line in the file:

Windows Registry Editor Version 5.00

"group/Keyword/Separator"=", "

I omitted this as I had no Win7 machine to test whether the version is “5.00” is working for Win7, too…

1 Like

Thank you very much for your for your valued assistance !
It is OK now !
I wish you a very good Christmas and New Year !

1 Like

Glad I could help you!

Happy holidays!

Hi Matthias,

JAbref work very well but I have a little problem (with the 3.8 release) : I have tried to use manual group and I can’t drag and drop in a manual group.
With the command “add to group” and it’s the same.
Sometime references appear then disappear.
Is it the same with le last Jabref release JAbref (3.8.2) because I haven’t update since my last problem. If I release JAbref do I have to do same command as below?
Thank you for your help,
Have a good day,

Dominique JACOB | Ingénieur d’Etudes-Veille
Corrodys : Centre de corrosion, corrosion marine et biocorrosion
Tel : 02 33 01 83 40 | Fax : 02 33 03 06 50 | Web : www.corrodys.com
145 Chemin de la Crespinière, BP 48, 50130 Cherbourg en Cotentin