JabRef not opening

JabRef used to work fine, but suddenly it stopped opening on my Windows 10 computer. It is visible in my task manager, but for the rest it does not open. I am not entirely sure what I did last time before it stopped opening that might have caused the problem: upgraded to 3.8.2, updated Java, or both. In any case, I tried re-installing JabRef 3.8.2, installing 3.7 instead, and re-installing Java. All with the same result. Any suggestions as to what might be the problem or what else I could try to identify it?

1 Like


It could just be the case that there is a message dialog in the background hiding JabRef’s window.
This happens when you did not exit JabRef the last time correctly or there were problems saving,

Did you try using Alt+Tab or Win + Tab to show the open windows?

If this doesn’t help there could be a problem with the settings.
In this case you should try to run the jar file via command line and check for potential erros

java -jar JabRef.jar


Ah! I think I see where the problem might be. I open two files, one in Dropbox, the other in OneDrive for Business. This is what I get:
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5.
22:38:27.062 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: C:\Users\xxx\Dropbox\xxx\litnotes Dropbox.bib
22:38:27.668 [AWT-EventQueue-0] INFO net.sf.jabref.logic.importer.OpenDatabase - Opening: C:\Users\xxx\xxx\Litnotes OneNote.bib
22:38:29.245 [AWT-EventQueue-0] ERROR net.sf.jabref.FallbackExceptionHandler - Uncaught exception Occurred in Thread[AWT-EventQueue-0,6,main]
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(Unknown Source) ~[?:1.8.0_121]
at net.sf.jabref.gui.JabRefFrame.updateAllTabTitles(JabRefFrame.java:1664) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.gui.JabRefFrame.addTab(JabRefFrame.java:1682) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.gui.JabRefFrame.addTab(JabRefFrame.java:1704) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.gui.JabRefFrame.addParserResult(JabRefFrame.java:1395) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.JabRefGUI.openWindow(JabRefGUI.java:134) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.JabRefGUI.(JabRefGUI.java:63) ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.JabRefMain.lambda$start$1(JabRefMain.java:128) ~[JabRef-3.8.2.jar:?]
at java.awt.event.InvocationEvent.dispatch(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventQueue.dispatchEventImpl(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventQueue.access$500(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventQueue$3.run(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventQueue$3.run(Unknown Source) ~[?:1.8.0_121]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_121]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventQueue.dispatchEvent(Unknown Source) ~[?:1.8.0_121]
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [?:1.8.0_121]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [?:1.8.0_121]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) [?:1.8.0_121]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:1.8.0_121]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:1.8.0_121]
at java.awt.EventDispatchThread.run(Unknown Source) [?:1.8.0_121]

Now my problem is that I have no idea how to change the settings (or delete them, to start over again) without opening JabRef. Is there a settings file I should open in a text editor?

I reset all settings by running the following line in the command window:
java -jar JabRef-3.8.2.jar --prdef all -n

Now it opens. I do wonder, though, what caused the problem in the first place.

The original problem (the exception you posted in JabRef not opening) should now be fixed as well.

Tobias, do you mean in a new version of Jabref? Because the current version still gives me the same problem. Every now and again I need to run it with the command above. It gives me the following warning:
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5.
Setting all preferences to default values.

I was refereeing to the the StringOutOfBoundsException. The warning could not open/create prefs root seems to be known problem with Windows. Maybe the fix suggested at http://stackoverflow.com/questions/16428098/groovy-shell-warning-could-not-open-create-prefs-root-node# helps.

Dear all,

I am encountering the same issue as Rolf did a few month ago, i.e. I have installed and used Jabref on Windows 7 and suddenly, it does not open any more (it seems to load after having double-clicked on it, but nothing happens). To solve this issue, I have tried to run the command that Rolf has suggested (java -jar JabRef-3.8.2.jar --prdef all -n), but it has not worked out for me… Does anyone encounter the same problem and would suggest another solution?

Many thanks in advance for your help!
Kind regards,

Can you try to run JabRef from the console using java -jar JabRef.jar. Hopefully you get some error messages that we can use as a starting point for further investigation.
You may also try out the latest development version.

Dear Tobias,

Thanks for your reply. I have ran the code you’ve suggested from the windows console and this message appeared : “Error: Unable to access jarfile Jabref.jar”… Do you have any further suggestions? Also, I’ll try out the latest version of Jabref and I’ll let you know how things are going.

The error message “Unable to access jarfile” suggests that java has problems finding JabRef. Maybe these links help: https://stackoverflow.com/questions/13617226/error-unable-to-access-jarfile-c-jar or https://stackoverflow.com/questions/11943948/error-unable-to-access-jar-file

My solution: open cmd as administrator C:\Windows\System32\cmd. Next, type:
java -jar “C:\Program Files\JabRef\JabRef-4.3.1.jar” --prdef all -n

None of the solutions work for me.

Same issue for me on Windows 10 1709. I updated to JabRef-4.3.1 but this didn’t help and the command line couldn’t find the jar. I ran the above quoted code and I got Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5. Setting all preferences to default values. and then the command line just sat there doing nothing. In the end I ctrl-c out and could start JabRef

@mercergeoinfo This is a bug in an old java version. Try to update your java version (64bit) to the latest one (202)

If the error afterwards still does exit:
Create a new text file with the following content and save it as javaprefs.reg
Afterwards you can double click on it and it will create the missing entry

Windows Registry Editor Version 5.00

OK, thanks.
But the bug has also denied me write access to bib files that the malfunctioning installation tried to open. I found no way of altering this either. I have full access according to Windows but as soon as I try to change anything I don’t have access. all I could do was open the files in Notepad ++ and copy paste the contents into new files.
Curious bug.

Hello everyone,

i am currently facing the same issues as described. About one month ago JabRef was working totally fine and suddendly it just stopped doing so. It is visible in my task manager beneath processes but it just won’t open. I already tried re-installing JabRef and Java and i restored default setting of JabRef like it was suggested in this thread - which actually worked, but JabRef itself sillt doesn’t.
I am using windows 7, Java 8 Update 221 and the lates version of JabRef. Any ideas what the problem might be?



you could try to use the latest development version, it ships with java 11 now: