Disable auto key generation

I would like the option to turn off auto key generation when entries are copied from one bib file to another. I tried to turn off this in the preferences, but it did not work.

Hi,

can you please test with the latest development version? There have been some fixes regarding the copying of entries from one library to another.
https://builds.jabref.org/main/

I tried v5.14 and it did not fix the issue. Just for clarity, what I am doing is:

  1. Open original bib file.
  2. File-> New library
  3. Select multiple entries in original bib file.
  4. Edit → Copy
  5. Go to new library tab.
  6. Edit → Paste.

Problem: It changes the cite key strings in the entries in the new library.

I think I remember that you have to disable


this option Generate nwe key for imported entries

1 Like

Thank you for the suggestion.
Unclicking the box beside “Generate a new key for imported entries” fixed the problem.
That is exactly what I needed.
Cheers.

1 Like

Hey @Siedlerchr,

Thank you so much for this amazing solution of this issue.