Entry preview behaviour of Location, URL and DOI fields in APA 7th Edition

I am using the Preview feature extensively to copy refs to other documents, using the American Psychological Association 7th Ed as the preview. (I would use any other similar reference format)
But it doesn’t display certain fields I consider necessary:

  • address for books: all I get is the publisher, but most publications require something like New York, NY: Wiley, rather than just Wiley.

  • URL field. I see DOIs, but not URLs

Is there another format that gives what I want or some way to edit the APA 7th Ed preview?

the adress for books apparently is not necessary anymore in APA 7th so this seems to be correct behaviour.

If an online work has both a DOI and a URL, include only the DOI.
If an online work has a URL but no DOI, include the URL in the reference as follows:

    • For works without DOIs from websites (not including academic research databases), provide a URL in the reference (as long as the URL will work for readers).
  • For works without DOIs from most academic research databases, do not include a URL or database information in the reference because these works are widely available. The reference should be the same as the reference for a print version of the work.
  • For works from databases that publish original, proprietary material available only in that database (such as the UpToDate database) or for works of limited circulation in databases (such as monographs in the ERIC database), include the name of the database or archive and the URL of the work. If the URL requires a login or is session-specific (meaning it will not resolve for readers), provide the URL of the database or archive home page or login page instead of the URL for the work. See the page on including database information in references for more information.
  • If the URL is no longer working or no longer provides readers access to the content you intend to cite, follow the guidance for works with no source.
  • Other alphanumeric identifiers such as the International Standard Book Number (ISBN) and the International Standard Serial Number (ISSN) are not included in APA Style references.

Source: DOIs and URLs

Could you please try what happens if there is no DOI?

Thanks; I switched to APA 6th Ed, which solved that problem

Still doesn’t solve the DOI problem. I’m using for Preview:
American Psychological Association 6th Edition (“doi:” DOI prefix)

For an entry like:

@Article{Friendly:2022,
  author   = {Michael Friendly},
  journal  = {Sociological Spectrum},
  title    = {The Life and Work of Andr\'e-Michel Guerry, Revisited},
  year     = {2022},
  note     = {accepted, May 15, 2022; Article ID: USLS 2078450},
  doi      = {10.1080/02732173.2022.2078450},
  eprint   = {https://www.datavis.ca/papers/guerryvie/GuerryLife2_v3.pdf},
  keywords = {moral statistics; crime mapping; history of social science; Quetelet; thematic cartography},
  owner    = {friendly},
}

the preview doesn’t show the DOI:

Friendly, M. (2022). The Life and Work of André-Michel Guerry, Revisited. Sociological Spectrum.

Cannot confirm.

Using that style + the entry you provided:

tested on

JabRef 5.6–2022-04-25–5c9d898
Linux 5.4.0-110-generic amd64
Java 17.0.2
JavaFX 18+12

Could you please provide the version of JabRef you are using? Could be that you have an older version an in a newer version this is already fixed. Could also be that you have to reset your preferences (please backup your preferences before doing so) or you have to restart JabRef, but I don’t think so. It worked for me immediately upon selecting the style.

That is strange. I’m using the same version, but don’t get the DOI in the preview window

JabRef 5.6–2022-04-25–5c9d898
Windows 7 6.1 amd64
Java 17.0.2
JavaFX 18+12

A DOI shows in the sample reference in the Options panel, but not in the Preview tab for my reference

I don’t know.

Things to try:

  • resetting preferences
  • reinstalling JabRef; Maybe try the portable version?
  • editing the citationstyle (only if all else fails).

Also, did you make sure you klicked on “save” after selecting the citationstyle? (Sorry, stupid question, but I am out of ideas now)
You also can switch between preview styles using F9 and Shift + F9

Is the DOI in the doi field in your entry? Maybe it’s not recognized as DOI…