Error while fetching from Medline


I have Jabref version 3.8.2 and I am having issues fetching from Medline (Springer, Google Scholar work fine).

This is the output from the console. Any ideas of what might be going wrong?

12:17:51.500 [JabRef CachedThreadPool] INFO net.sf.jabref.logic.importer.fetcher.MedlineFetcher - 61 results found. Only 50 relevant results will be fetched by default.
12:18:21.616 [JabRef CachedThreadPool] ERROR net.sf.jabref.gui.importer.fetcher.SearchBasedEntryFetcher - Error while fetching from Medline
net.sf.jabref.logic.importer.FetcherException: Error while fetching from Medline
at net.sf.jabref.logic.importer.fetcher.MedlineFetcher.fetchMedline( ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.logic.importer.fetcher.MedlineFetcher.performSearch( ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.gui.importer.fetcher.SearchBasedEntryFetcher.processQuery( ~[JabRef-3.8.2.jar:?]
at net.sf.jabref.gui.importer.fetcher.GeneralFetcher.lambda$actionPerformed$5( ~[JabRef-3.8.2.jar:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_121]
at [?:1.8.0_121]
Caused by: Server returned HTTP response code: 502 for URL:
at ~[?:1.8.0_121]
at ~[?:1.8.0_121]
at ~[?:1.8.0_121]
at net.sf.jabref.logic.importer.fetcher.MedlineFetcher.fetchMedline( ~[JabRef-3.8.2.jar:?]
… 6 more

Thank you,


Just to add more info, my search term was “NODDI”, and the search works fine if I search directly in

I think we fixed this issue recently. Can you please try out the latest development version (please make make a backup of your database before)

It is indeed working fine on this latest development version, thank you very much!

1 Like

Hi there,
I just updated the latest version ( and have still no access to pubmed and google scholar.

“Error while fetching from Google Scholar. Please try again later/and or check your network connection. Cookie configuration for google scholar failed”.

Any ideas?

Thank you

@Lisawein This is strange. It works for me and also our automatic tests run without failure. Is it just pubmed and google scholar that are not working for you? Do you get further logs in the error console?

@Lisa: Despite an updated JabRef, Google Scholar might still be blocking JabRef if it got blocked before. Usually, all you have to do is a manual search in Google Scholar in the browser, answer a captcha, and then JabRef should be able to import again. At least this worked for other people before.