Force JabRef to write absolute file paths to bib-file

Hey folks,
I am using JabRef for many years now and want to thank everyone involved for creating a wonderful application! :slight_smile:

However, I have a very urgent problem now (I have done hours of research in the documentation and the forum before, there are obviously a couple of people with the same problem but I couldn’t find any solution yet…).
As far as I see, JabRef has recently changed its behaviour to writing relative paths to .bib-file when linking pdfs - and there doesn’t seem to be any option anymore to change that behaviour!? This, however, makes JabRef kind of unusable for me now. That is because I am using JabRef in the first place for managing my references - but I am working with these references in other applications (means that e.g. I need to open the linked file attachment from within another application). This worked fine as long as JabRef either wrote the correct file path to the .bib-file or I could force the other application to search for pdfs in a formerly defined default directory. In my current case, both options aren’t available.

Or do I miss anything? How can I force JabRef to write the absolute file path in my *.bib?

Thanks for any help or suggestions!


I need identical functionality. The following almost/kind of worked for me under Linux:

  • Under “Options” → “Preferences” → “Linked files” set:
    • “Main file directory”: “/”
    • Unset “Search and store files relative to library file location”
    • “File directory pattern” to the full path. For instance /home/somebody/somedir/[bibtexkey]

The resulting bib removes the first “/” (using multiple / or escaping it with \ did not work). It seems to work at least with helm-bibtex, but I would like, though, to have the full path, starting with “/”, since the lack of the first “/” prevents me from opening the PDF by directly from the bibtex file.