Override file links - path to linked files

I am running JabRef 5.2 on a Ubuntu 20.04 system.
On my hard disk, I have a folder with my Mendeley files.
In JabRef, I have loaded the corresponding bib file.

I have read this help page in order to link the entries in JabRef to their corresponding pdf files in the Mendeley folder, to no avail.
The link set in both /Options/Preferences/Linked files and /Library/Library properties are ignored.

What can I do to make this work?

Hi,

Please check if you have ticked the checkbox (“Search and stores files relative to the library location”) directly beneath the “Main file directory” under Options Preferences.
You need to uncheck that because it will take precedence over all other options,

Thanks Christoph. I have unchecked the box, but this did not solve the problem. JabRef insists on a path in which it repeats my home folder twice (see screenshot) - even when I remove my preferred path (see screenshot in post below).

Screenshot_2021-04-12_08-58-47

Settings:

@Henk_Harmsen , could you try with the latest version of JabRef, and don’t forget to save a backup of your library beforehand.

I haven’t set the properties of the library, but this is my preference window,

and I can’t replicate the problematic paths.

I have installed JabRef 5.3.
and put the settings as in your screenshot

the path still seems to be ignored
screenshot_1

Hum, that is weird. It looks like it skips file:// for some reason.

Does it work as a temporary workaround if you set the pdf-viewer manually in JabRef preferences → External programs → Manage external file types → pdf?

Is your path maybe a symlink? I am not sure if JabRef resolves them