How to do a complete uninstall of JabRef - Windows 10

Hi everyone,

How can one do a compete uninstall of JabRef on Windows 10? I have tried uninstalling via control panel and then deleting the org.jabref folder in AppData\Local, but after reinstalling JabRef (tried both with current and previous versions) the program would also open the last file opened before uninstalling, signaling me that not every piece of data was cleared. My customized preferences were also still there.

(Do not know if it is appropriate to add this here, but I need to re-install fresh as my JabRef does not apply changes to Citation Key generation preferences, and I’d want to see if the issue can be solved by installing the app fresh, before reporting the bug on GitHub).


on Windows, JabRef stores the preferences in the Registry. You can also reset the preferences in JabRef itself. Regarding the citation key changes (Did you press ENTER after changing the pattern)

Thanks for the reply. I know you must press enter first and the save button second for the preference to be recorded. But that is exactly the issue that I am having, when I change my preferences (successfully, at least according to the fact that thr writing “Preferences Recorded” appears on screen) these changes are not actually applied when generating a new key. Other than this, key generation works fine and if I change, say, the author name and overwrite the existing key, JabRef does so successfully, but it does so according to the old preference which I have overwritten. I can’t even get it to reset to “factory settings”. This is why I would like to perform a complete uninstall before I report the bug on GitHub.