Jabref 5.4 crashes

After updating to version 5.4 from 5.3 I was able to load my BIB DB. However, after reopening I have only problems. I have no more access to my DB. :hot_face: In the middle of the Jabref window appears the message: no content in table. But the program is “dead”; no action possible anymore. After actions like “Repair” or after uninstalling and reinstalling, Jabref is not responsive: The Jabref window opens and only the message: no content in table.
In the folder I find the files: JabRef-BibTeX.bib.sav.tmp (0 bytes) and or JabRef-BibTeX.bib.sav (313 bytes).
How can I solve this Problem? The only bright spot is I have a copy of the BIB file :grinning:

My System: WIN10 Version 20H2

Could you please make a backup of both

  • JabRef-BibTeX.bib.sav.tmp (0 bytes)
  • JabRef-BibTeX.bib.sav (313 bytes)

and then delete both from the folder?
I have heard in some cases it resolved some issues.
The .sav.tmp file seems suspicious anyway. ‘tmp’ implies it is supposed to be a temporary file and not supposed to exist permanently.
The other file, the .sav is supposed to be there. It is a backup of your library. You could use it by renaming it to JabRef-BibTeX.bib

Also, does Jabref start if you open it directly without any bibfile? (e.g. by moving your bibfiles to another folder Jabref would fail to find it and therefore start without it)

It would be nice to see the “working” bib file. Can you share it here or to vorstand AT jabref doooot org?

This refs Fix exception when saving and autosave trigger at the same time by Siedlerchr · Pull Request #6694 · JabRef/jabref · GitHub

Thanks for the feedback:
I have done the following steps:

  1. uninstalled JabRef program and reinstalled.
  2. then tested a new DB.BIB everything ok
  3. then loaded “old” Patent.BIB => ok
  4. one entry changed and tried to save (see fig)

    see nest post
  1. message: The lib has been modified by another program
  2. then review changes
  3. Error message
  4. after all different tests I finally get: no content in table and and the program is no longer responsive.
  5. I try to upload a Patent.BIB
  6. Hope that this contributes to the solution

wrong image:

I tried to upload the BIBI file but received the message

Better send the bib file to developers@jabref.org
Can you also expand the details of the stack trace?

Can you also expand the details of the stack trace?
How can I do this?

I have sent a test BIB file to: developers@jabref.org

Thanks. We received your file. Can you click on “Show details” in the error dialog?

Repair or remove is not sufficient to reinstall the program. After repair as well as after remove and subsequent reopening/reinstall the program is not accessible. Only the message: no content in table appears in the middle of the JabRef window. The Program shows no activity! It is not responsive.
Furthermore “Show details” in the error dialog is therefore not possible as described above.
To reinstall the program all leftovers (residuals) must be deleted. (search all leftover files containing “jabref” and delete them; without regedit).
I’m really curious what is causing this error, especially since it shows up on others as well.
Good night! :smiley:

Correction (yesterday evening was too long :hot_face:):

Only the file JabRef-BibTeX.bib.sav.tmp must be deleted.

  1. copy the BIB file from the backup drive to the literature folder (to start from scratch)
  2. start JabRef
  3. open the BIB file if not already loaded
  4. due to background tasks are running it took a long time to finish (5632 entries; (JabRef-BibTeX.bib.sav.tmp occurs; I delete this file)
  5. save the BIB file
  6. message: The Library has been modified by another program
  7. click on the Dismiss changes button
  8. quit Jabref
  9. open JabRef
    then the following Jabref window opens

    Jabref is now unresponsive.
    Jabref must be removed with the help of Task Manager


can you please try this version? The exception should not longer occur index - powered by h5ai v0.29.0 (https://larsjung.de/h5ai/)

see forum contribution: An important bug!