Lack of entry preview styles

After downloading the app I have very limited amount of entry preview styles. I have some additional styles that I want to have in JabRef, repo is: GitHub - citation-style-language/styles: Official repository for Citation Style Language (CSL) citation styles.

How can I include more styles? Thank you, the app is awesome!

1 Like


this seems like an issue from our side that during the build the styles were not copied over. Normally, we ship all CSL styles available. We are investigating this issue already and hope to resolve it asap.


I tried with today’s build - and it works (downloaded from index - powered by h5ai v0.30.0 (

Seems, we need to craft a new release :sweat_smile:

@annalog I need some more information on this. Where did you download the app? Which OS are you on? I tried the portable versions of JabRef 5.9 and 5.10 for Windows from Releases · JabRef/jabref · GitHub and all show fine.

I also tried the Windows Sandbox and downloaded JabRef 5.10 from Release JabRef Version 5.10 · JabRef/jabref · GitHub (the .msi file). It also worked. Thus, no influence from my local development setup (IMHO)

In case the version you show is build from source directly (without using our GitHub actions build script), the CSL files are not included. Maybe, you checked out the source and did “./gradlew run”? In case you want to have all CSL files available in the development version too, “just” copy over eveything from “buildres/csl” to “src/main/resources”

We will work on a simplified setup

I am on MacOS 14.0. JabRef got from here: JabRef download latest version - it’s the page I get directed to from here - JabRef - Free Reference Manager - Stay on top of your Literature. I tried reinstalling the app today, but the styles are still unavailable.

Where can I find “buildres/csl” and “src/main/resources” to copy the styles?


we are fixing our build setup and will make a new version with the fixes

I can confirm @Anna’s observation: the problem is with the MacOS version of jabref. The full set of csl preview options appears on Linux and Windows versions of jabref, but not MacOS.

I just triggered a build for a new de version which fixes this and also is properly signed + notarized. I will post the link here later

@ratramnus @annalog You can now find a new version here:
(I recommend installing the pkg version, as we also fixed some issues regarding the extension)

Omg, that’s awesome! Thanks!

1 Like

Thank you so much Christoph! I do appreciate it very much.

1 Like

The fix is now included in the 5.11 release binary as well!