MacOS SIERRA : totally broken

Sorry if this is the wrong place but I am lost. I upgraded my Mac to Sierra (10.12.2) and Jabref starts (3.8.1) but apart from quitting and editing preferences I can do nothing. No menus, no windows. Totally broken. It looks like people have met some problems with Sierra but nothing like this one. Possibly not a bug from JabRef that is why I post here and hope to get some advice about what to do to try to solve this issue!


Not that it helps you much, but I am having the same problem with basically all versions. I have tried every single version since 3.5 onwards and never got past the same behavior. I am running OS X 10.12.3 (but it failed with 10.11 already), and Java 8 Update 121. I have uninstalled and reinstalled and always get to the same spot.


Update: So I guess this is a machine-specific issue, as I tried installing it in my Mac Pro (2008), running OS X 10.11, and it runs fine. I don’t have my library there, but that is another problem. LOL.

Thanks for your insights,

could you please specify some details?`E.g. architecture/ OSx version / etc?
Maybe this helps others with the same problem


Yep… Jabref 3.8.1 still broken for me.

What details would you need?

Hello, I have the exact same problem. I upgraded to OS 10.13 and updated Java and now Jabref simply won’t turn on at all (the GUI never appears).

@mariouka2805 Version 4? Did you upgrade your java? JabRef requires java 8., it is not yet compatible with 9