Order files by name during PDF-file import via "Search for unlinked local files"

I suggest to add an Order by file name choice in the window for Search for unlinked local files that would allow to order the files list following the alphabetic order of the names and not in order of their age,

I have a directory with many files that wait already for some time to be added to my jabref-bibtex file. Now, I want to add one these files by Search for unlinked local files and have look for this file in a list in order of their age which takes some time (I do not know why, but the drap & drop method does not seem to work for me now.)
I think that also other people will have a similar experience.


Please vote if you support this proposal:

  • I would like to have this feature, too!
  • I don’t care.
0 voters

How many files are we talking about? Linking files should be fairly speedy.

Another alternative you could try would to use autolinking files via using a regular search expression in the preferences and to use the “automatically set file links (F7)” feature. See also Manage associated files | JabRef. This option also does not order pdf-file import alphabetically though.

The overall number of unlinked files is 300-600.

Maybe linking files is farily speedy for other people, but if I try to import one pdf-file via the pdf-import and wait for 2 minutes with the output in the UI indicating that 0 % of the file has been processed, I stop this import and use the “look for a doi in the pdf-File, copy it, create new entry in database by using this doi and linking afterwards the pdf-file by the add file feature of jabref”-method.
And when I am working with this entry can be that somehow a further entry for the corresponding file is showing up, i.e. it seems that somehow jabref was able to import the pdf-file, but the UI did not indicate this.

That sounds more like there is an issue accessing that file. Some locations or files on your computer might be read/write protected.

I do not think that this in an issue accessing the file, at least not only.
Since latter there was an entry in the database that seemed to be created while I waited in front of the 0% indication, I believe that there is a communication problem between the UI and the PDF Fetcher, or there was at least one in JabRef 5.13.
When I tried to reproduce this problem with JabRef 5.15, I waited for some seconds in front of the 0% indication screen without any change in the number but then suddenly there appeared this window indicating that this file was successfully loaded and the shown list of entries in my bibtex file was updated.
So maybe in JabRef 5.13 the activation of this indication window and the update of the list had not worked. Or I was to fast with my inputs for my large file and created somehow a race-condition.

I observed that now after fetching a pdf file using the drag & drop method the list of entries is also updated and I believe that this was not the case in JabRef 5.13, such that I assumed that the drag & drop me method did no longer work, but is still pointed out on this page, in view of the This page is partly outdated. remark on this webpage.