Problems saving database: "Save failed during backup creation. Save without backup?"

I have been using JabRef for a couple of years now with no problems. All of a sudden when I tried to save a database, the dialogue box saying > “Save failed during backup creation. Save without backup?” is popping up. If I click yes, it won’t save and says > “Status: Save failed”. If I try and close it anyway, I jut get the dialogue box that doesn’t close that says > “Waiting for operation to save and finish…”

What is going on here??? I didn’t do anything differently here, I’ve been using the same database. Only change was I tried to copy one reference from one database to another. All databases are having this problem now!! Please help!

This sounds quite weird…

Can you please tell us which version of JabRef you are using on which operating system?

Hi there Matthias,

Yes very weird! I’m using version 2.7b on Ubuntu 12.04. I’ve been using the same version now for almost 3 years and have never had any problems!

Any ideas?

Honestly: No.

Can you check whether the error console (Help -> Error Console) is showing something useful?

However, this version of JabRef is really old and no longer actively maintained.

You should try using a more recent version which is available here:

Please make a backup of your bib-Database before opening it in JabRef 3.6 as there have been massive changes in the code and functionality since v2.7b


Ok I’ll just try doing that… really really stupid question here but how do I make a backup?

That is even a beta version, isn’t it?

For a backup, you can just copy your bib file to another folder.

Just a side note: Nearly all versions of Ubuntu 12.04 have reached end of life years ago. I hope you are on 12.05.5 LTS, because otherwise your system is running without security updates. Even that version will expire in a few months. See:

Ugh I know… I’ll be honest, I’m not confident at all in ubuntu and I’ve been kinda scared to upgrade in case other things don’t work!! Is there a good step-by-step guide to backing up/upgrading?

Ok so here’s another problem… I can’t actually quit jabref because it won’t save and close! I tried finding it and closing it using “top” but I can’t see jabref!

Can you see “java” in top?

Hi mlep, sorry but on top of where?

You mentioned using the software “top” to find the JabRef process.
The report of the software “top” may mention “java” instead of jabref.
Alternatively, you may use the following command line to find the process number (and then kill it):
ps -ef | grep -i java

Oh wow, of course that’s what you meant. So I am intermittently seeing java in top… I saw it a second ago but then it went away

It makes sense: Top is designed to display only the processes using the most the processor. So, if JabRef is doing nothing, you will not see it.

ok so yes this worked to close and when I reopened JabRef, all seems ok again??? Very weird

I have found your problem was reported earlier:
By earlier, I mean in 2010… Saving was done to a netdrive, but no further diagnosis was done.
Anyway, as underlined by @joerg.lenhard, both your version of JabRef and your OS are outdated. It may be time for an update!


While I am using ubuntu 18.04 LTS (64 bit) and jabref 3.8.2, I encounter the exact same problem as stated above. When saving a file I get the error:

“Save failed during backup creation. Save without backup”

If I click “yes” I get the message “save failed”.

Yet it seems the file has been saved? So in a way that would be ok.
But at the same time I can not exit jabref, since I then get the error:

‘Database has changed …’

Asking again to save the file, and as such going in loops.
Only killing the process via system manager works.

FYI: I just tried the version 4.2, and I actually get the exact same problem. Any ideas?


do you have Autosave library enabled?
Maybe there are some right problems?