V3.8.2 (x64 windows) : problem saving large .BIB libraries

I recently ‘upgraded’ to v3.8.2 (x64 windows). Unfortunately I am now UNABLE to save my database; the program just hangs up “saving…” … Is there a quick fix for this? Very troubling…I have 7000 entries.

After more troubleshooting, it appears I cannot save the database if it contains more than 729 entries… (???) …Previously I worked with a library of 7000 entries (v.2.10) – the only reason I switched versions was because I could no longer import from PubMed due to security changes of some sort (?)

Should I downgrade to v3.7? or another version? the new release did not work either - it got stuck up

After yet even more troubleshooting, I have made further observations:

If I load my 7000-entry .BIB file in jabref v.2.10, and then resave the whole thing as a new .bib file, that takes ~20 seconds;

If I load the same 7000-entry .BIB file in jabref v.3.6, 3.7, or 3.8.2, the system hangs up “Saving…” …however smaller BIB files save fine. SO, is there some issue with LARGE BIB files in these new versions that solved the one problem (no PubMed Access) ??

There is no problem with huge databases per se. I suspect that one entry (probably the 729th or 730th) is screwing something up in JabRef.
Could you please send the bib file to developers@jabref.org so that we can investigate this problem in more detail?

It would be difficult to send by email, as it’s 15GB. I might be able to post it online to a OneDrive account for example for download?

sorry, 15MB that is…but still large for email

That would be fine too!
(Do you mean 15 mb? 15 GB sounds really large. We only need the bib file and not the attached pdf’s.)

Thanks for the file. I can reproduce the problem and will have a look at it!

Thanks, is there any progress on this front?

Sorry, it took me a while to solve this problem. Hopefully, you can download a working version from http://builds.jabref.org/fixSave/. Note that this version includes a few other changes that are still on a beta-level (especially some features in the groups panel are still missing). Thus, please be careful and create a backup of your database.

Thanks a lot Tobias… unfortunately I am now encountering a new
problem…When I tried to import a new record from PubMed, it got hung
up while “processing X et al.” … does this sound familiar? best, Matt


A quick update : I WAS able to import the record from PubMed, but there
was a much longer delay than usual when “processing”…not sure what the
cause may be (?) … On the upside, the graphical display looks much
sharper now, as it did in version 2.10 (java update?), and the load and
save times for the libraries is MUCH faster (thank you!!)

…maybe there is something going on with the PubMed interfacing?
best, Matt

I’m glad the fix worked for you and you positively noticed some of our recent work (we constantly try to improve the performance and UI).
We have automatic tests in place for the PubMed fetcher and they report that everything is working as expected. Maybe they had temporary problems with their servers. Please keep us updated if the problem persists.

Thanks Tobias… I do still experience a delay of about 12-14 seconds
for a new record to be added from PubMed; the search itself brings up
the hits right away without delay, but to actually add it to the
database, it says “processing…” for about 12 seconds. Maybe this is
standard, although for prior versions, I remember new entries being
added almost instantaneously. Can this issue be recapitulated ?

Also, maybe this relates to the ongoing work still being done on
"groups"(?), but I noticed that new entries don’t seem to be
automatically added to the currently-selected group, but rather are
simply added to the “all entries” master group containing the whole
library. In prior versions, this was not an issue.

Thanks for ongoing help! I plan to donate in the near future to JabRef,
as I find it to be a fantastic program constantly undergoing
improvements. These points above would be great to see updates for.

Best, Matt

Thanks for the follow-up, Matt! I could replicate the long delay after adding the search result and tried to fix it. You can download a new version from http://builds.jabref.org/protecedTermsFormatter/. While the delay is (hopefully) smaller than before, it is still longer than I would like it to be.

The “automatically add entries to selected group” issue will take a bit longer and its progress is tracked as part of https://github.com/JabRef/jabref/issues/2599.