Step 2 of the contributors guide fails: Set up the build system: JDK and Gradle

Hi there,
I am new to Jabref, and wanted to pick up an issue and set up my local workspace to get started. I got stuck at Step 2 of the guide:
However, no modules show up on the list for me, and I can only add a single model “Jabref” to the list, as opposed to three modules already showing up in the guide.
This also makes the gradle build fail later in the guide.
Can someone update the guide to match the current grade setup, or guide me on how to overcome this issue?

@koppor @calixtus can you check?

You can’t override compiler parameters for JabRef.main module, right?

Actually, no modules are present when I import the project into IntelliJ. Later on, I can only add the JabRef module, not the JobRef.main module. Thus, I cannot set the compiler parameters for the JabRef.main module, as it is not visible to IntelliJ.

Hi Endre. Did you follow step 1 to the word? Like opening the project using build.gradle?

I did follow Step 1 precisely.
I have just found out what is missing from the guide. You need to reload the gradle project before going to Step 2, and then those modules will become visible in the settings.
Maybe something has changed recently in how IntelliJ imports gradle projects. Thus, I think this hint should be included in the guide.

1 Like

@Endre_Palatinus Great to here that it’s solved.
Feel free to modify the guide accordingly jabref/docs/getting-into-the-code/guidelines-for-setting-up-a-local-workspace at main · JabRef/jabref · GitHub

@Endre_Palatinus Oh, wow. I didn’t knew. However, I tried to reproduce with a fresh checkout (local clone of the repository into another directory) and I did not have the issue. Maybe, we just need to add “wait until the lower right corner of IntelliJ does not show any activity any more”. Reason: The import and indexing takes more than 10 seconds. If you continue to setup after 3 seconds, the import is not finished.