JabRef 4.0 Autogenerate bibtex keys should follow bibtexkey pattern

(Len) #1

Autogenerate bibtex keys should follow the pattern specified in preferences.

For example, set pattern to [authforeini][auth][year] but pattern is not followed when key is generated in

Quality … Autogenerate Bibtex key

nor when key is generated in Web Search (e.g. IEEEXplore).

Please vote if you support this proposal:

  • I would like to have this feature, too!
  • I don’t care.

0 voters

(Bernhard Kleine) #2

I do not see where the problem is. Here the keys are autogenerated.

(Len) #3

The problem is… The autogenerated key is always in the form [auth][year] irrespective of the preferences setting. This makes the preferences setting of little use.

(Bernhard Kleine) #4

these are imported through the medline/webinterface
7-10 are imported through [auth][year], the others using [authshort][shortyear]. The preference is changed in Options->Preferences->Bibtex-Key-Generator and saved. IMHO this has been working flawlessly since long.