4.2 Crashing on OSX El Capitan

When I try to import references Jabref freezes. I’ve tried reinstalling to no effect. Version 3.8 works fine so I’ve gone back to that.

Unfortunately the lack of comment field in 3.8 means all my comments are lost. At present I’m not considering Jabref a viable option for research.

we are sorry to hear that. Unfortuantely there seems to currently a lot of problems which seem to only affect mac users. Most of the devs don’t have a Mac and we are currently a bit low on dev resources as we develop JabRef in our freetime. So it makes it hard to reproduce this and to find out why this happens.

Have you tried deleting JabRef manually from the application folder, so that the installed jre also gets removed?
And have you tried the latest development build?

I have the same problem with JabRef 4.3.1 working with Mojave 10.14.2. I cannot import new reference, JabRef turn forever and it is necessary to force quit the application.

Hi, have you tried the latest development build? (Remember to make a copy of your library first)

Thanks Christoph. The new build works fine!