Fonts do now show up following installation of JabRef in Linux

I downloaded the Linux portable version of JabRef and extracted the tar.gz file with tar zxvf JabRef.... JabRef opens but the fonts do not show up and therefore the text on the console cannot be viewed (e.g., File, Edit … etc these do not show up, and neither would the text of any reference show up in the console).
Can you please provide some guidance as to how to fix this problem? I tried to search online but there does not seem to be any solution.
OS: ArchLinux ThinkPad X220i
Kind Regards,
Arindam Basu

Hi Arindam, im Carl, one of the maintainers of JabRef. I use Arch Linux myself, but I never had any issue like this before. Maybe it’s something about your configuration of gtk or your windowmanager? Are you using x11 or wayland? There are still some issues with JavaFX and Wayland. Are you using Gnome or KDE or something else? Maybe some dependency is not installed? Can you please try to install the rpm package? What dependencies does package manager ask for?

Regards, Carl

Thanks Carl. I am using X11 with Gnome. It is possible that there are some dependency issues that may have remained unresolved. I unzipped the zipped JabRef file and tried to run from the bin folder.

Hi Carl,
I tried everything possible:

  • Rebuilding from the JabRef AUR repository: there I ran into an unresolvable issue with Gradle
  • Then I tried installing from RPM. This did install the package but it was no different from installing it from the Linux binaries that were distributed and I found the following error message:

// —
May 26, 2023 11:39:23 AM com.sun.javafx.application.PlatformImpl startup
WARNING: Unsupported JavaFX configuration: classes were loaded from ‘module org.jabref.merged.module’, isAutomatic: false, isOpen: true
2023-05-26 11:39:27 [JavaFX Application Thread] org.jabref.gui.StateManager.setActiveDatabase()
INFO: No open database detected
2023-05-26 11:39:27 [JavaFX Application Thread] org.jabref.gui.theme.ThemeManager.updateThemeSettings()
INFO: Not updating theme because it hasn’t changed
2023-05-26 11:39:27 [JavaFX Application Thread] org.jabref.gui.theme.ThemeManager.updateThemeSettings()
INFO: Theme set to Theme{type=DEFAULT, name=‘’} with base css StyleSheet{jrt:/org.jabref/org/jabref/gui/Base.css}

(JabRef:25171): Gdk-WARNING **: 11:39:27.486: XSetErrorHandler() called with a GDK error trap pushed. Don’t do that.
May 26, 2023 11:39:27 AM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
WARNING: Resource “” not found.
May 26, 2023 11:39:34 AM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
WARNING: Resource “” not found.
The system is X11 and it does seem that JavaFx is doing something, :-),
I have archlinux java status showing
java-17-openjdk (default)

I have given up.
Any thoughts?
My machine runs on Gnome as Window Manager, and it has Archlinux latest build.

Arindam Basu

This is the problem, see

In case it helps, I am using wayland, not X11, from echo $XDG_SESSION_TYPE
Sorry for the earlier wrong message.
Interestingly, if I install via Gnome apps, JabRef installs regularly and fonts, etc all show up.

have you tried to open /lib/runtime/bin/JabRef ? bin/JabRef does not always work. "

Edit: Also, if the Linux version of JabRef portable is put into a folder named bin , it will not start. Other names are fine, like apps ."

Edit²: If you build from source, currently, jdk 19 is required.

Thanks @ThiloteE . I tried each of the steps you indicated here, same results. As I wrote, JabRef loads following installation but it does not load the fonts so, that even though I can see the icons, I cannot see or read any text on the JabRef window as such. It seems ONLY for Linux (Archlinux) with wayland and possibly with JavaFX and GPT3(?), there may be a something (a bug, possibly) that does not allow rendering of fonts on the console or Xwindows? From what I read on StackOverflow and elsewhere, it does not seem that we can do anything at the end of the users to fix this (but I am happy to be corrected). This seems to be a very specific and limited error only for some combination of platforms and OSs. On the other hand, if I were to install JabRef using Gnome application which bundles the App as Flatpack app, JabRef not only loads but shows the fonts and the renders them correctly on the window and is usable to store and work with references. However, there is another vexing problem with that kind of installation. JabRef, while renders everything, is functionally limited in those settings as this will not allow me to use JabRef’s excellent bridge to LibreOffice to load and inject citations into LibreOffice texts. It will still push citations to Emacs and friends. This use case does not affect me particularly because I use Emacs to write my papers, but I cannot recommend this solution.

So, in the end, we need to find a solution to this issue: JavaFX with Wayland and GTK3 has problems with rendering text on JabRef post-installation.

Can you try another javafx app like scene builder or else (see jfx central has a list of some popular javafx apps)?
Would be narrowing down the cause auf the issue.

Thanks @calixtus
I installed openjfx in ArchLinux and then attempted to rebuild JabRef 5.10.1 from rpm; this time it works as it should.


Great, happy citing!

Thanks Carl. Will it be helpful if I put the PKGBUILD and associated files for the Archlinux and add to the README of a git repo that installation of something like openjfx might be helpful if anyone wants to install JabRef on Archlinux on Wayland, this might be useful. This may save some people from the grief of what I went through. As there is already an Archlinux package I think (although I could not get it to run due to issues with gradlew that I could not solve yet), I found that using the RPM + PKGBUILD script and then doing makepkg -si in the same folder worked this time.

Thanks again for your kind and helpful messages, greatly appreciate it. I honestly believe that this level of kindness, helpful attitude, and community feeling is unique to JabRef, even among free and open source software community. JabRef stands out!

@arinbasu You’re welcome! Thanks for the investigation. You are welcome to add a small section to the FAQ for Arch Linux Linux - JabRef (Top right corner, Edit on github)