Get BibTeX info from DOI failing


When I attempt to get BibTeX data from a DOI I get a response code 406, which, according to CrossCite, means “406 Can’t serve any requested content type.”

Any ideas why this might be happening?


I have a similar issue on Windows: After trying to add a new entry by selecting ID type DOI and ID (paste DOI here, have tried multiple, even ones that worked in the past), I get the message: “Error while fetching from DOI. Invalid URL”.

Edit: Version is

JabRef 3.8.2
windows 7 6.1 amd64 
Java 1.8.0_121

I have opened an issue on github:

On a similar note, it seems that the link with crossref may be broken. Cannot fetch bibtex info based on the doi, e.g. 10.1016/j.enpol.2019.03.001 returns nothing (“Cannot get info based on given doi”) while finds it easily. The crossref web search from JabRef returns a bunch of articles but not the actual one. Has the API Changed or anything else?

JabRef 4.3.1
Windows 10 10.0 x86
Java 1.8.0_201


this is odd. JabRef queries for the given doi and at least the online website gives a result.
Have you entered the DOI via New Entry -> DOI or you could alternatively paste the doi on the maintable.


It originally failed returning any result while importing new articles in the database. I then tried using the get bibtex info from the entry itself which did not return any results. Using a new entry returns “Fetcher doi did not find an entry for id ‘10.1016/j.enpol.2019.03.001’”.
In general, it does not find any bibtex info on all recent articles that I am uploading in my database (all referenced in crossref so I can find them all online). But looking at some older articles I have, the bibtex info are extracted from crossref. I am not sure what can it be related to.


using the latest development version, it works fine for me.
As the Article seems to be relatively new, I guess it may need take some time until the DOI link is visible/working.

Please try the latest development version. Remember to make a backup of your database.

Yes that might have been the issue, all the bunch of recent articles I was importing worked to fetch the bibtex info from the doi as of today (about 2 weeks delay). I am a little bit surprised as I have been keeping my database updated for a while even for (very) recent articles and never ran into that issue so far.
Thanks for taking the time!