How to report problems in the distributed version 5.14 ensuring that one can no longer work with jabref?


after my Jabref was updated from version 5.13 to 5.14 by snap, I can no longer use the programany longer and I would like to report these corresponding error. But, I do not want to create problems for me by trying to install your famous developer version or telling lies about using this version in your fine GitHub bug report form.

So, is there any way we would like to be and forced users of JabRef 5.14 could report our problems, or are these error not of interest and you would like to keep them in the code that is shared now, since they may have disappeared in your developer version?


Hello Olaf,

A workaround for now would be to go to the path /snap/jabref/3221/lib/runtime and run JabRef as program (right cllick “Run as program”)

We are currently tracking this issue at jabref snap fails to start on ubuntu · Issue #11465 · JabRef/jabref · GitHub

I apologize for the inconvenience. Could you report back, if the workaround works for you?

1 Like

@OlafKlein you can also try out the snap version from --edge channel there it’s fixed.
we plan to release a new version asap

Dear ThiloteE,

thanks for this workaround. (For other potential users, I would like to point out that from the path /snap/jabref/3221/lib/runtime I used bin/JabRef in the shell the start JabRef.) This workaround also solves the other problem with Error message I had after starting the updated version of JabRef. It seems that by using this workaround as side effect some old status is reloaded, e.g. the files the the recent files list seems to the files I had opened in 2022 or 2023. This may by the status when I used the mobile version of JabRef for the last time.

Dear Christoph,

thanks for your remark. I have successfully tried the snap version from the edge channel. I am just not sure if it is a bug or a feature that the existing preference file seems to be ignored.
Concerning the preference file: I tried to load a preference file that I had created with JabRef 5.13 into the new jabref version. When i pressed the save bottom in the Preferences windows afterwards the following error message window appeared:


The content of error message were:
errors.txt (12.1 KB)

My preferences file is
pref-2024-07-09.xml (45.3 KB)

Maybe this is only a problem for me, but this may also be a problem for other users of JabRef who would like to continue to use their old preferences.

we could reproduce the error with saving the preferences you had and have fixed it. The Preferences were nonetheless correctly migrated. e.g changing to a Dark theme and then updating, JabRef kept the preferences.

A new release 5.15 is ready now.

Dear Christoph,

thank you.
As I side remark: When I managed to start JabRef 5.14 without using the workarounds discussed above it did not work properly. For example, loading this preference file did not only created an error message, but also somehow damaged my JabRef, see my remark on the github server,