Import from Bookends or Endnote

I just installed JabRef on Ubuntu, because I need a reference manager which is OS-independent. Yet, I have a library with attached pdf-files in Bookends and Endnote and have to migrate them to JabRef.
The import from Bookends doesn`t work at all.
The import from Endnote partially works, however the paths to the pdfs are gone and some fields don’t show up in JabRef. It seems only a small number of fields can be imported using the Bibtex-style-file.

Endnote and Bookends and JabRef are up to date.

JabRef seems to be an interesting project, but without any documentation how somebody can migrate an existing library (+pdfs) to JabRef… I cannot use it :wink:

Maybe I should add that I have around 3000 references in Bookends/Endnote connected to about 2500 pdf-files. So I cannot do it manually.

Nice to hear that you are giving JabRef a shot!

How do you do the migration, i.e., which formats do you use for export in Bookends/Endnote? I think both programs can export to RIS, which JabRef can import. So this would be my natural first choice. You say that some fields and the paths get lost in the process. Can you please have a look at the file exported by endnote and check if the information is present there. If endnote does not export some fields, then there is nothing we can do on JabRef’s side. On the other hand, if the data is in the file and JabRef fails to import it, then we can of course fix this. (The problem is that there is no agreed-upon standard for RIS and everybody is inventing their own fields…)

Moreover, even if the import of the paths to the attached pdf’s does not work, not all hope is lost. JabRef has a few features that allow you to automatically attach files to a given entry. This works pretty nicely if the file names follow a certain pattern. But first we should focus on the correct import…

Thanks! You are right, most export-filters don’t work. In Bookends there is one export option, which offers an Endnote-xml-style. It contains all the info, but of course JabRef does not know how to handle it. (example is attached)Library1.bdb.xml (5.3 KB)

When I export from Bookends using RIS. Most of the field-infos are gone. Bibliography.bib (2.3 KB)

Can you also please attach the exported RIS file. Thanks.

I just realized that it only offers a RIS-format in a bib-file. 50

or some other file-formats, but all contain only a fraction of the field infos.


the Endnote-xml-export (Bookends) is the only one, which contains all fields. Here is another reference.
Library2.bdb.xml (4.5 KB)

ok, since the endnote xml is also used by other reference managers and there is actually something like a standard, I’ll have a look the next days and write an importer for it. But it may take some time.

Pointers for me:

Thanks a lot. No problem, if it takes some time. If you want me to test your xml-import-files (alpha, beta) just let me know. :slight_smile:

@reinhard I now finished a first version of the importer. You can find the build at It would be nice if you could try out if it works for you. If there are any problems (not imported fields, error messages or logs in the help > error console), please let me know and I’ll improve the importer. Since I couldn’t find a proper documentation of the format, it was a bit of a guessing game - so maybe some data is missing or in the wrong place.

Thanks a lot! I tried it on a Mac. JabRef freezes when I try to import the endnote-xml-file. The Mac error report is attached. errorreport.txt (1.0 MB)

Tried it on Ubuntu 17.10. Same thing…
Don’t know if the log is related to the problem

Connection timed out. Read timed out
at Method)
at org.jabref.logic.remote.shared.Protocol.receiveMessage(
at org.jabref.logic.remote.client.RemoteListenerClient.sendToActiveJabRefInstance(
at org.jabref.JabRefMain.start(
at org.jabref.JabRefMain.lambda$start$0(
at java.awt.event.InvocationEvent.dispatch(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
   Cannot use port 6050 for remote operation; another application may be using it. Try specifying another port.

This is really strange. I asked the other developers who use Linux or MacOS if they can reproduce the problem. I’ll keep you updated as soon as we have found a fix. Just to make sure that we are not looking at the wrong place: JabRef freezes after you clicked on File > Import into new library, selected the xml file and the EndNote XML file type, and confirmed the dialog with ok, right?

Can you please try to run the following command from the terminal:

java -jar JabRef--importBookends--latest.jar -i Library.xml,endnote -o Library.bib

Yes, that’s correct.
I will run the command in the evening. Thanks


the exception looks like you already have an instance of JabRef open which could interfer with this.
I tested this under Xubuntu 16.04 and it works fine. No issues.

Regarding the problems with freeze. Could you please check if your java version is up to date? Latest version of Java 8. (no java 9).


Ubuntu 17.10, Java 8
Maybe it is related to the fact that the export file (Bookends) is named library1.bdb.xml? I renamed it to library.xml and it seems to work now. I have to check again.
When I use the terminal it still shows some errors:

user@user-Swift-SF315-41:~/Downloads$ java -jar JabRef–importBookends–latest.jar -i Library.xml,endnote -o Library.bib
AI: INFO 12-02-2018 15:13, 21: Configuration file has been successfully found as resource
Importing: Library.xml
Saving: Library.bib
File: grouptree.fxml not found, attempting with camel case
File: grouptree.css not found, attempting with camel case

When I try to import using the program (not the terminal) I get this

org-jabref-jabrefmain antwortet nicht (tranlsation: does not respond)

When I use the terminal
java -jar JabRef–importBookends–latest.jar -i Library2.xml,endnote -o Library.bib
with a library.xml file containing just 1 reference it works, but I get the grouptree-errors, mentioned above.

Imported reference looks VERY GOOD! :wink: