Pubmed search in JabRef 5.2--2020-11-10--f5c52a2 doesn't seem to work?

Folks:
Still new to Jabref, moving over from Bookends to new linux computer with JabRef 5.2–2020-11-10–f5c52a2 which I went to to try to get “endnote xml” files exported from BE imported into Jabref, and there were some problems . . . got my main database imported into Jabref OK, although it didn’t seem to link the attached pdfs as expected or explained by the BE owner . . . .

But, new problem, my “workflow” is to search through email digests of search queries and then import studies that look of interest using ref manager “search” of the PMID number. In my earlier edition of Jabref 5.2 I tested that out and it worked fine. Today I tried running the “find and import” dialog in Jabref dev 5.2+ and it found “0” items . . . I tried the number and I tried “pmid: xxxxxx” . . . gave it a full minute, nothing showed up??
Is there a way to test out to see if it is working, but the admin at Nat’l Library of medicine is blocking services on that end???

New day . . . tried again, searching for a single pmid number . . . window opens shows “processing xxxxxxx” . . . but bottom corner “items found 0” . . . .

Just for humor I tried another pmid number from today’s digest, same deal . . . nada passa . . . .

Have you some example pmid I can try?

Christoph Siedlerchr
November 15

Have you some example pmid I can try?

1 selected item: 29016274 - PubMed

Is the one that brought the issue to my attention, but I tried another one out of a number of digests . . . both failed to retrieve anything . . . .

When I go to Library -> New entry -> pubmed/medline and enter the id, it works fine for me. Maybe it was a temporay problem with the medline servers?

@Siedlerchr:

OK, I didn’t try it that way, I was using the “search” >Pubmed down at the bottom left, where Pubmed is in a list of drop down items to select from. Then a search dialog window opens and it says in the middle of the window “processing 29016274” . . . but nothing gets processed . . . .

I historically used this method in BE to retrieve references that I pre-read via the digest emails . . . and I did it in the Jabref 5.2 edition that the Pop!_OS store provided for my first installation of Jabref . . . and it worked to find and enter the reference into the library, so it was working in Jabref, but now, possibly not??

I didn’t try the Library >New entry method . . . because, old habits, and because using the “Search” box at the bottom did seem to work in stable Jabref 5.2 before that we went to the newest devel edition to get the import the “endnote xml” files function working . . . .

I’ll be back in that laptop in awhile, so I’ll test out your method in a bit, not sure if that makes an extra step or if it’s “‘6’ to one, ‘half dozen’ to another,” etc???

Over in Jabref a minute or so back, it’s the “web search” feature that I’m referring to that doesn’t seem to be retrieving anything. I checked the >Library >New entry and there didn’t seem to be any “pubmed” entry, but I again tried to use the web search area where there is a pubmed listing . . . again brought nothing . . . . The “new entry” window was open for adding data, but I like to be able to retrieve the listing from Pubmed search and then auto-add that into the ref manager . . . ?? It worked before as I expected it to, but seems like in the dev 5.2+ . . . not???

Got the idea that maybe the web search feature isn’t good with numbers, so I tried again with the 29016274 as the search and again it brings nothing. Then I searched “acupuncture AND depression” and there was a “moment” of hesitation, maybe 30 seconds and then “50 references” loaded!!!

But, I wasn’t sure if those were “new” references newly found, or if it “found” them in my 5K library items . . . I again pasted the 29016274 and . . . back to nothing. Just for humor I again ran the “acupuncture AND depression” search, and this time it also brought “0” found???

Then I typed “pmid: 29016274” . . . and again that brought nothing. Before I started typing this email I ran another search . . . “acupuncture AND lymphedema” . . . to wit, it was still “processing” and yet not finding anything . . . .

So from that seat of the pants trial, it appears that the “web search” feature is “intermittent”???

You are right, the medline/pubmed web search uses a different endpoint for searching based on keywords, it doesn’t work with the PMID. IDs are handled by the new Entry dialog (e.g arxiv, doi, isbn)
Tip: You can also directly paste a DOI on the main table and JabRef will do the magic

The web search is really searching the publisher’s db.
And it’s using the medline/pubmed central. It’s limited to loading 50 references because of the publicher’s restrictions.
Sometimes the Medline/Pubmed is also slow or you just have to wait a bit.

To conplete existing data, you can also do a right click => Get Bibliographic data from…

Thanks for the reply . . . so I got the difference between key word and pmid searches . . . . I did get a New entry entered in the library using the pmid number as I have done with BE in the past 14 years or so . . . so that part is maybe on the “good foot” . . . . I couldn’t figure out what “pasting the DOI on the main table” means . . . does that mean clicking on a library and then “pasting” a DOI there?? I actually don’t know what DOI is, as I mainly am using Pubmed and their pmid numbers to connect to the reference . . . .

Still, it seemed like yesterday the key word web search feature was “intermittent” . . . and then continuing to play with Jabref, today’s “experiment” was to close the library and then try to use the “open library” dialog to find and open the library that I was just using . . . but, nope, didn’t show up in the “open” dialog window at all . . . tried it a couple of ways, nothing showing to be opened??? I went to “recent libraries” . . . and that worked to open the library . . . .

So, I shall endeavor to persevere with it . . . still seems like a learning curve . . . old dog, etc. : - )

Hi,

DOI = Digital Object Identifier, it’s a kind of unique, persistent url for the resource (e.g the document),


JabRef can directly get bibtex data for a DOI. You can simply paste a DOI number with ctrl+v on the entry table and JabRef will create a new entry.
I guess PMID is a similar thing (except that you cannot paste it direclty on the table)

Regarding open library: You just to select the bib file under which you saved the library.
If you move the mouse over the library tab title you will see the path of the library.
We recently fixed an issue where for new libraries the title was still saying “untitled”
You can always find the latest dev version of JabRef here:

Christoph:

Thanks kindly for the reply . . . I’ll check into the DOI method . . . not sure if I recall seeing that in Pubmed, which is more or less my sole source for gathering references.

I did “find” that “untitled” issue, but somehow managed to get it saved under a name, not sure if that created a new database/library . . . but, still, I do know where my libraries are stashed, and the “open” dialogue opens to the directory, but, shows nothing in there, possibly it’s looking for “Bibtex”??? (bottom right corner for file type, of which no option to change it) . . . there should be four libraries to “find” . . . but it isn’t showing me the library that I was just adding an entry to . . . via “open” . . . . Only going to “recent library” or something like that in File> library??? does it open . . . mild complaint level.

And, OK, got it on the upgrading to latest dev option . . . how often are new editions coming out?? I’d like to get it so that “apt” will be finding upgrades to installed apps like Jabref . . . is that a possibility . . . or in dev mode it’s always going to be owner-operator upgrades???

Hi,
libraries are simply stored in the file system with the .bib extension When you do a mouse over of the tab you will see the path.
You can also do File -> Save library as.

Regarding new versions. A new development version is automatically build every time some code changes happen. Sometimes its just some external libraries and no bug fixes/features.

We provide jabref as snap package, the dev version can be installed using the edge channel.

The snap version is more security restricted (sandboxed) and cannot connect to LibreOffice or other external Editors.

@Siedlerchr:

Appreciate the conversation . . . I guess I am coming closer to actually needing to read the manual, which I try to avoid if at all possible, I’m an “Install first, then read instructions” kind of a guy . . . clicking on stuff, see what happens . . . .

I did go to Pubmed and ran a key word search and picked an item and I did find the DOI number, and somehow I figured out >click on >new entry icon, that opened a blank entry?? I pasted or cntrl V’d the DOI number, and indeed, there was the entry title . . . but no “abstract” was loaded . . . ??? Looking around to see if the Free Full Text article could be linked to the new entry . . . didn’t seem to be obvious??

My minimal “need” is that either by pmid or DOI I could import an item, and the abstract would be there, and then a simple way to download and import the associated full text article . . . ???

I did find “search for unlinked local files” . . . because I believe I have 117 pdfs that were exported from BE that need to be manually linked up in Jabref, I’m in my big database where most of the attached pdfs would be wanted, but it seemed to be pulling all of the pdfs, whereas a number of them would be going to other libraries . . . . I tried to click or 2x click on the “attached file” icon in the line entry to the left of the title . . . some of the line items show that icon, but again, nothing opened?? I thought you mentioned some feature about “auto-linking attachments” . . . didn’t see that feature in the obvious menus . . . ?? Seems like I have to go through the pdfs and figure out which ones go to which library, then “search for unlinked local files”??? which it did open the correct directory to do that, it just selected ALL of them w/o regard to which library they should be going to . . . .

Still playing with it, but seems like it should be “simple” to import reference + abstract + full text connected to the line item . . . the rest, like setting up “sub-groups” by topic would be less important, but was a feature of BE . . . .

So far I would add that “snap” isn’t something that works for me . . . I would want to link to LibreOffice writer, etc.

Hi,

Your workflow:
New entry -> Enter pmid -> Then afterwards select the new entry -> Lookup -> Lookup Fulltext online.
Then JabRef will search online for the fulltext pdf and download it. Note that you need to configure a directory for your files first.

Getting abstracts depend on the publisher and article, they are often copyrighted.

I really suggest having a look at the getting started guide:

Regarding files and the auto linking etc:

Thanks for the insights . . . it’s getting better, I did manage to get the Free Full Text attached to my sample new entry, so it’s just a matter of knowing the different tools that Jabref is using compared to BE . . . .

I will look through that “auto-linking” information to get the old pdfs connected up, just have a lot going on and reading instructions is like sitting in bumper to bumper traffic . . . “going nowhere,” compared to being up on the freeway flying along, when “actually doing something” like entering pmid numbers and downloading associated pdfs, etc. I do appreciate your time in helping this old guy get up on the Jabref “freeway” . . . . : - )))

@Siedlerchr

I have more or less figured out how to get my old libraries imported, and using “right-click” on the item that shows an old attachment, and selecting “attach file” added the local file attachment, while still leaving the old Bookends pathway icon there as well . . . wouldn’t mind cleaning those old pathways out now that Jabref has them hooked up, so to speak.

But, I do have to say that the “untitled” problem is still continuing in my dev edition of Jabref, I just imported three of my libraries yesterday and today, clicked “import to new library” “save library” dialog now openes in the proper diretory, but name entered emains as “untitled” . . . until I linked some attachments, then, new name is showing. However in my last library there are no attachments, “save all” goes through and saves the libraries, shows the latest one with an error, “changes have been made by another app” . . . in this case only one change, accepted the changes . . . name remains as “untitled.” Possibly if I quit Jabref it might restart with new name?? I’ll test that, this has been an issue for all four of the imported libraries since I started posting here . . . point being the problem is still extant. Pop!_OS 20.10 . . . .

Following up, yes, quitting the app seems to get the saved name to show up.

I also tried closing the library and then “open library” to see if that would work to get the new name to show up . . . but no libraries showed up from among the four??

Only “recent libraries” showed the four, including the last library saved under the new name . . . the “open library” dialog doesn’t seem to show its own file type of library . . . ???

Hi, this souds a bit odd. The problem with the untiteld should be solved in the latest development version.

The libraries are simply bib files, you should be able to see them in the file explorer in your file system. Can you check if the libraries have the correct .bib extension?

The issue with changes by other is a known problem which happens sometimes when savings. You can usually ignore them.

Checking the libraries that Jabref imported, right-click and >properties the files aren’t showing .bib file extension, they have no file extension . . . under file type they show as “MATLAB file” . . . and there are the .bak files as well . . . I think one has the .sav file extension.

I recall in the previous 5.2 edition of Jabref that Pop!_store installed, importing the libraries went to a .bib file type, but in this dev edition, doesn’t seem to be showing them with .bib??? Now I have a fair bit of work in these libraries getting the attachments hooked up, is it possible to just add “.bib” onto the end of the file name using “rename”???