Interface with cryptic unreadable font

JabRef version 5.0 and latest dev (5.1) on Windows 10
java 1.8.0_251, OpenJDK version “12” 2019-03-19

When I open JabRef, my Interface shows up like shown in the Screenshot: link
I downloaded both, the stable portable version for windows, and the latest development version, both have this issue.

I had Jabref installed before, but I uninstalled it, because this issue started appearing seemingly random. So this could be an issue with some configuration, that was loaded. One more indicator, that this is the case, shows, that it loaded my library without me telling it, where it is.

So besides the question, if anybody nows, where this comes from, i would like to know, where the portable versions look for configurations? Maybe i could “clean” this in a first attempt, so JabRef writes them again.

Any help is appreciated :slight_smile:

EDIT: I should say this too: In an earlier try, i also found out, that the language is still set to english. So, not just a simple “wrong language” error.


this looks odd. JabRef uses the systems font. Try to reset the preferences under options -> Preferences.
Maybe the encoding is wrong and the language?

first of all thanks for the reply! I reset the preferences, and nothing changed. I did expect that, because, as mentioned, it was a freshly downloaded jabref, and I tried this before…
the language is set to ENGLISH, and the encoding is UTF-8. I confirmed this by typing “ENGLISH” and “UTF-8” into the search bar and compare the resulting gibberish to the gibberish in the settings, where the language and the encoding is set.

I narrowed this down to a user-problem: the exact same JabRef (i copied the folder to a shared drive) works on a second user on the same pc! So I controlled env-Variables, java-settings, and everything, but I cant find the difference, that leads to this error. This is why I think, there must be something saved for the user, thats somehow broken…

Okay, On Windows 10 JabRef stores the preferences in the registry:
You can simply delete the entries under the jabref key: (simply execute regedit and navigate to)


You might also check if you have somewhere a JabRef.xml settings file for the current user. When portable mode is enabled, JabRef additionally exports the prefs to the xml file.

okay, i deleted the entries, and I run “jabref-X.Y.exe -d all -n”, which does the same, i believe. I didn’t know about the xml, but I now deleted that, too. But nothing helped, still the same error.

Ok, so I installed the latest java-openjdk and removed any old ones. I installed JabRef, instead of running it as portable version. Every time, it worked in the other user, but not in my current one. So I think, this has something to do with settings for windows-users, but I really dont know, which settings… Since this is not really reconstructable, and I’m the only one with this problem, I’ll see if i can fix this, or if I really have to create a new dev-user…

Okay, thanks for the feeedback. Indeed very odd.

Are other applications also affected?