JabRef-4.0.jar on OpenBSD fails

Hello !

I tried JabRef-4.0.jar and JabRef–master–latest.jar on OpenBSD using

java -version                                             
openjdk version "1.8.0_144"
OpenJDK Runtime Environment (build 1.8.0_144-b01)
OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)


/usr/local/jdk-1.8.0/bin/java -jar JabRef-4.0.jar

which displays the error

Fehler: Hauptklasse org.jabref.JabRefMain konnte nicht gefunden oder geladen werden

EN : could not find or load main class org.jabref.JabRefMain

Can I do something to get JabRef to work ? FYI there is no other jre / jdk version available.

Thanks for help.

EDIT : use text formatting.

You need OpenJFX for JabRef 4.0. The command sudo apt-get install openjfx should install everything you need. Further details can be found in the Installation guide.

Thanks for your answer apt-get is a Debian / Ubuntu package manager but I use a BSD. As I wrote before, there is no JavaFX available on OpenBSD (as far as I know). Is there a JabRef version available for download which does not require JavaFX ?

I read somewhere that pkg install openjfx8-devel worked. Maybe it does the trick also for you. All versions since 4.0 depend on JavaFX since we are in the progress to migrate to this new UI framework. You can still use one of the old 3.8.* releases.

Thanks for your answer. The version 3.8.2 let’s say works. But Java is sooo slow even on a quad core i7 with 32 GB RAM.

We hugely improved the performance in 4.0 and again in 4.1. Maybe you find a way to install OpenJFX on BSD. If so, please write here how you did it and even better add it to the installation guide. Sorry for the inconvenience caused.

@nawi-is A quick googling led me to this page which seems of offer ports

And also this site which lists it:

Thanks but booth are FreeBSD only ports. OpenBSD ports could be found for example at openports.se I try to ask a maintainer.