JabRef build failed for Haiku OS, please help

I was trying to build JabRef (https://www.jabref.org) from source. I downloaded the source code and then unpacked the zipped file in the ~/config/non-packaged/bin directory and ran

./gradlew from within the directory to build it.
The build process failed, resulting in the following message:

 Configure project :
Project : => 'org.jabref' Java module

FAILURE: Build failed with an exception.

* Where:
Build file '/boot/home/config/non-packaged/bin/jabref/build.gradle' line: 14

* What went wrong:
An exception occurred applying plugin request [id: 'org.openjfx.javafxplugin', version: '0.1.0']
> Failed to apply plugin 'org.openjfx.javafxplugin'.
   > Could not create an instance of type org.openjfx.gradle.JavaFXOptions.
      > unknown os.name: Haiku

At that point, further search on this error message sent me to a rabbit hole and it seems I cannot anything till gradle or os checker includes haiku in their list, if I understand correctly.

Is there a solution that I can use?

This question is perhaps more suited to the gradle team, but in case you can provide some guidance, that would be great.
Also, since Haiku OS at this stage supports java jar files, is it possible to have a JabRef jar file like we used to have in the past, please?

Arindam Basu


yes, the issue is coming from the openjfx gradle plugin javafx-gradle-plugin/src/main/java/org/openjfx/gradle/JavaFXPlatform.java at master · openjfx/javafx-gradle-plugin · GitHub

Have you tried running the portable version of JabRef? That should also work out of the box, JabRef ships the necessary sdk with it


Thanks Christoph.
As the system is Haiku OS, not linux, therefore I could not find a suitable JabRef portable for it. I tried with the Linux portable version of JabRef, but unfortunately it did not work.

Can you run from the terminal and or check for logs? https://docs.jabref.org/advanced/commandline https://docs.jabref.org/faq/osx#q-where-can-i-find-jabrefs-log-files