Build-Error – Jabref update from the AUR on GNU/Linux Manjaro

Hey everyone,

Im using Jabref since quite a time now. A few months ago i switched from Ubuntu to Manjaro. Installing Jabref from the AUR using yay worked fine.

Now, today i tried to update Jabref usin yay. During the build() process of the package the following error occured and the build was cancelled:

==> Beginne build()...
Using JDK from /usr/lib/jvm/java-17-openjdk to build JabRef.

Welcome to Gradle 7.5.1!

Here are the highlights of this release:
 - Support for Java 18
 - Support for building with Groovy 4
 - Much more responsive continuous builds
 - Improved diagnostics for dependency resolution

For more details see

To honour the JVM settings for this build a single-use Daemon process will be forked. See
Daemon will be stopped at the end of the build 

> Configure project :
Project : => 'org.jabref' Java module

> Task :compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Could not resolve all files for configuration ':compileClasspath'.
   > Could not resolve com.github.JabRef:afterburner.fx:testmoduleinfo-SNAPSHOT.
     Required by:
         project :
      > Could not resolve com.github.JabRef:afterburner.fx:testmoduleinfo-SNAPSHOT.
         > Unable to load Maven meta-data from
            > Could not GET ''. Received status code 521 from server:

My system is running jre-openjdk Version 19. gradle is temporary installed within the build-process. Im not confident using Java, so its unclear if the error arose from the PKGBUILD-file or my own Java-installation.

Its the first time i write a bug here. So, please, if this is the wrong place for an error report like this, just tell me :wink:




this is just a temporary issue. I had the same issue today. We rely on jitpack for that, We are planning to publish it as normal version soon.

PS: JabRef does not yet build fully with openjdk19 (jlink and jpackage issues). So we recommend you either use jdk17 or jdk18

Hi Christoph,

thanks for the fast reply. The error also occured using jdk17. But if its only temporary, im fine with it. Version 5.7 still works very well.

I will give short feedback here when the update was successfull.


You could also try the portable version in the meantime

Hi Christoph and the Jabref-Team,

installation went without problems today through yay


1 Like

Happy New Year!
Thanks for the feedback!