Jabref not displaying Japanese characters


I’m hoping someone could help point me in the right direction with my problem; I tried searching both this forum, the documentation and the github issues for any solution, but to no avail.

My version info:
JabRef 5.2–ArchLinux–1
Linux 5.10.11-arch1-1 amd64
Java 15.0.2

I was initially using JabRef about a year or so ago to create a small .bib file that I shared with others on a website via BibBase. Worked like a charm, loved it. Since then, JabRef has been updated on my system (looking cool, btw), but now is unable to display the Japanese characters correctly. All other applications on my system correctly display them, and the .bib file is also correct.

Out of curiousity, I also tried to see what happens if I switch the language to Japanese, and the problem persists except for the window title…

thanks for using JabRef!

You probably need to install a CJK (Chinese Japanese Korean) font to correctly display the characters. Fonts - ArchWiki

Otherwise I know that some others in the forum are also using arch and can maybe say more about this

Hello Christoph!

Thanks for the tip! I had adobe-source-han-sans-jp-fonts installed, which worked for everything else (and I guess the window title?), but turns out I needed otf-ipafont for JabRef. Installing it solved the problem! :+1:

@adober Nice to hear that it works!
Maybe you can add your solution to the install instructions for linux Installation - JabRef
(just click on edit at github)

@Siedlerchr Of course! I added a small sub-heading to the troubleshooting section. :slight_smile:

1 Like