JabRef version for Mac OS 10.6.8 (latest Snow Leopard)? - Is there an OS requirement list available?

What is the last version of JabRef running on Mac OS 10.6?
(I have tried the Mac version 3.6 from https://www.fosshub.com/JabRef.html, but upon attempting to install it, there is an error message reading that it would require Mac OS 10.7.3 or newer).
(I have also tried the Mac version 3.3 from https://github.com/JabRef/jabref/releases, but version 3.3 wouldn’t run on Mac OS 10.6 either).
Unfortunately, I couln’t find a list with JabRef versions and their OS requirements.

Thank you very much already in advance.

I’m not an Mac expert so I can’t tell you what exactly is causing the trouble with the JabRef installer.

It seems to be that Java 8 cannot be installed on Mac OS X 10.6.X (see for example http://stackoverflow.com/questions/24995066/how-to-install-jdk-8-on-mac-os-x-snow-leopard) - and Java 8 is required since JabRef 3.0.

Thank you very much for your helpful reply, indicating that this issue seems to have to do with Java.

Actually, I found that even for Java 7 (and later versions) “you will need an Intel-based Mac running Mac OS X version 10.7.3 (Lion) and above”, according to https://java.com/en/download/faq/java_mac.xml.

What is the last version of JabRef requiring less than Java 7, i.e. running with Java 6?
Where can it be downloaded still?

P.S.: Thank you also for the link to the stackoverflow.com thread on how to possibly install Java 8 on Mac OS 10.6, but being a Mac user rather than a Mac expert, I feel that I don’t want to make any of these changes after which I couldn’t be sure that my OS would still be running smoothly afterwards.

This should be version “2.11 beta 4” which is available here: JabRef - Browse Files at SourceForge.net

Another option would be to use Parallels or another virtualization software like Virtual Box on your mac to run a Linux, for example.
Then you would be able to use the latest JabRef version with Java 8.

Best Regards

@matthiasgeiger Thank you very much for your quick reply and helping me find this version!

(I just downloaded the file, unzipped it by doubleclicking it, then doubleclicked the extracted file JabRef_Java6 with a blue JabRef icon - but rather than to start installing itself, nothing happens unfortunately.
I don’t really expect you to come up with a solution to this problem, but I feel might be because it is a zip rather than a .dmg or .jar file, and maybe the installer is missing).

@Siedlerchr Christian Thank you very much for your suggestion!
Taking into account the issue not getting the Java 6 version installed (as I just described above in reply to matthiasgeiger), I might give the idea with virtualization a try.

Best Regards,

Honestly I just don’t know how to deal with this “app” for Mac OS X. However, there is jar in the folder JabRef_Java6.app\Contents\Resources\Java within the zip file.

This should be executable using Java 6.

Thank you very much for this indication in which folder jar should be located, and I’m sure I’ll get it executed and running now.