JabRef 5.6 requires Mac OS 10.14 or higher

Well, that, I had version 5.5 installed and seeing the new version notice in the program, I downloaded it from the web, both the dmg and the installer and both install a version that is incompatible with my 10.11 system. In fact, the application includes the prohibited symbol.

I understand that if this new version is not compatible, the program should not warn about it, or at most simply a message that it exists, but that it will not be compatible and I have to update the mac first before being able to install it. In addition, I have not been able to find any reference to the minimum requirements of the application on the web either. Not everyone is using the latest OS version or machines this year, and that’s a basic piece of information to inform users whether or not they can use the program. I would like them to continue supporting my system (and previous ones), but I understand that it is not feasible with the time that has passed since its launch and its obsolescence. But at least that data should appear. And if different versions are also linked for each system, it would be much more useful and interesting. One of the reasons for using free and open source software is precisely that: to be able to use “old-fashioned” systems without the problem generated by paid programs, which even if you pay, do not offer you a functional version in your system.


Thanks for your feedback. Please excuse the inconvenience. This is something we just weren’t aware of.
From what I read, this seems to be related to singing and notarizing the application package and that JabRef is built on the Mac system at the GithHub CI level and packaged. You should be able to run the portable version
You can download it from here:

Hi, thanks for replying, but I’m afraid you still need a system higher than 10.12, at least the two versions I’ve seen: 5.6 and 5.7 in the portable package for mac. Both with the prohibited symbol and generating a system message informing about it.
I had previously tested the package with the disk image (dmg), and I assume that the pkg will be similar to the result. Rather, I understand that some of the used libraries or other options is what forces us to upload requirements.
In addition to reporting it, just in case it was an inadvertent bug, my intention was to request that the help page should report on those requirements, whatever they are. It is something that I have not been able to find, and I understand that many will find it very opportune to meet them. To avoid submitting complaints about it not working, when it turns out that the requirements are what they are. And if you don’t comply with them, it’s going to work badly. It avoids wasting the user’s time, but also the programmers responding to problems that are not. It’s something I don’t get on a lot of shows lately. It’s as if they assume that EVERYONE is using the LATEST version of everything, at any given time.

At the moment I have reinstalled the previous version and tried to use it for a while. Or maybe try other options like Mendeley, Zotero or others.



Thanks for the additional feedback! As a last resort, you can try to build JabRef yourself and test if it works.
You only need jdk17 + Gradle to compile and run JabRef (can be installed via brew) (I just updated the docs, it was still mentioning v13)

So maybe the fault is in the necessary jdk version… jdk17 is certified as of 10.14, can it still be installed on older systems? Are the requirements to install it different from those needed to use the obtained programs? All this speaking without any knowledge, I don’t know how to program nor would I know where to start. If I have installed Xcode, NetBeans, and some other IDE but in the end I have not used them at all, at most I manage to compile the sample application and little else, and sometimes not even that :frowning:

If you indeed want to compile from source, Installation requirements for Mac OS can be found here: Installation of the JDK on macOS

I visited that same link the other day, and as they explain JDK17 requires 10.14 or higher in order to be installed. So I understand that any program that requires it should also need to run on 10.14 or higher as well. My doubt is that if it is the same to install JDK and use it to create a program, or if it is the same to simply run a program created with that version of JDK. And my opinion is yes. Also the installers from Orable or AdoptOpenJDK, or rather Temurin have higher requirements. So I understand that this is the problem to get Jabref running on my system. Something they should consider reporting it. If only to avoid claims and waste time responding to them.

I am already tired of trying to use programs that do not work. I have already deleted this week half a hundred of them that gave me problems. Either I’ve reverted to previous versions or I just abandon them, period. Has no sense. They don’t even bother to report if it works or not. Or if the problem is the processor as in other cases. Not the slightest mention. Everything is trying and looking for life. That’s why I no longer pay for anything I can’t prove beforehand. Or I look for free versions or that at least have a demo. And of course, forget about having support. Many have it today, but tomorrow they leave you without mention. And I am clear that the next computer, be it mac or not, its price will be much lower. And it will be thrown away after six months. Spot. Superenvironmentalism that takes, they say.

@MacTerrassa Thanks for the clarification. Is there a reason you cannot upgrade to a newer OS version?

Thank you again for notifying us all about the incompatibility with this older Mac OS version. JabRef is run by volunteers that are willing to spend their free time on the project. There clearly is and was no intent to “hide” such information from users. There is a multitude of operating systems out there and developers only have limited capabilities to test all of them and make it work for all of them. Would you mind helping out updating the documentation?

Also, could you clarify, where exactly you would want users to be notified about having to use a certain version of JabRef? (As I see it on FossHub, there is no possibility to attach comments to a setup-file).

With regard to updating or not updating: This your personal choice. There are benefits and downsides to updating. You have mentioned it yourself: You want to use the latest version of JabRef. Probably because you expect the latest version is the best. Since the newest version is not compatible with your older operating system and you prefer to stay on your older system or are unable to update to a newer version, you probably will have to accept having to use an older version of JabRef as well (or use another app). At least for the time being.

Hello, I am using two iMac Intel Core 2 Duo, from 2007. These cannot be updated beyond El Capitan or 10.11.6.

I understand that the ideal place to inform would be the main page and link to the versions for different operating systems, or at least indicate to look for such a version for such a system. It always seemed to me one of the advantages of free programs: to continue offering support to old systems. Not only with the current version, but also allowing the download and use of previous versions. But that requires indicating those requirements. That I have not been able to see neither on the main page, nor on the change log page, which I do not see any version of the operating system.

Of course, if I don’t see any mention of requirement changes, I assume they will be the same as the previous version. And therefore, it always seems to me that a program is improving and repairing bugs, therefore it is interesting to update. Yes you can. And when this is not the case, if they indicate it, you decide whether to continue using the previous version, if you change the program or if it is time to renew the machine and upgrade. And if we talk so much about ecology, it seems to me that the latest is not always necessary and if you make the most of the acquired devices.

My complaint is that those requirements are not stated on their home page nor that I see in the help, or on the changelog page. I understand that they are basic data, if only to differentiate not meeting those requirements, whatever they may be, from some other bug in the program that can (or cannot) be repaired. And save time for everyone, developers and users. If you are aware of a minimum to be able to use the program, the logical thing is to communicate it. And then who can use it or not.

I understand.

Please help us out: https://docs.jabref.org/contributing#i-am-not-a-programmer. You can add this information to the documentation.