Java Error on JabRef

I am having some difficulty with Java on JabRef since the update to JabRef 4.1. I get the following error message when I open the program:


What’s odd about this is the Java version I have on my machine is 8.0_151, so I am not sure where JabRef is pulling from with this outdated version or how to update it.

Thanks in advance for any help!

Sometimes Java installs a new version but does not remove the old one. You can, however, manually remove the old versions and then this warning message should disappear.


So, I have this exact problem as well, and I have tried removing all Java-stuff on the computer, both using their version check/uninstall utility and manually, and the problem still persists. I have also updated/reinstalled JabRef.

I also get some bugs which might be related to this somehow - one being that sometimes when I add a new entry to my library, all fields, for all entries, disappear in the GUI. I have to restart the program for this to be reset.

I am running Windows 10 Enterprise v. 1709 build 16299.192.



you should check your (system) environment variables if there is still a JAVA_HOME (from an old installation left).
Since a while Oracle java installation are added to the PATH variable as C:\ProgramData\Oracle\Java\javapath
If the cleanup does not work, you can still add the folder point to the \bin subdir from the current java installation.

Just a note: Java 9 is not yet supported


@jmurphy8289 @JonasBjorklund

I improved the error dialog and it should now display the Java installation directory. You can download the new version here:

Update: it is now included in the current development version

I had the same problem after the update like @jmurphy8289. Ich followed the advices and not I got this:FehlerJavaJabref
Actually, I remove Java and Jab, install both following your webside. But nothing change. Only i got the olf error massage, like @jmurphy8289 showed at the beginng.
Thanks for help

I just wann update: I follow the path and, look, there was an old version of Java (2016). I delete everything (old version, Java 8 and Jabref) and install it again. Problem solved.


I solved the same problem by:
Step 1. Trying to install the latest version of Jabref provided by Tobias and then deleting the old version of Java showed in the installation directory (in the error dialog).
Step 2. Installing a newer version of Java Runtime Environment in:
Step 3. Installing Jabref again, and there you go!
Hope it helps.