Version 4 issues

I recently upgraded from 64bit version 3.8 to 4 on a Windows 10 pc. The interface looks much better. Nevertheless, there are some bugs in the new version. However, there is a one big bug, which makes me wish to switch back to version 3.8: Whenever I click an entry to edit, the editing window opens with tabs. But I can only see fields in the first tab and edit them. If I click other tabs, there is nothing showing up. Sometimes even the first tab does not show anything. This bug essentially prevents me from editing the existing entries. I tried the development version too and it does not help. I tried to switch back to version 3.8. But it appears that the version 4 uses a different bib file as version 3.8 since I won’t see any of my groups after I switch back from 4 to 3.8. Now I am stuck in version 4 and have to use an text editor to make changes in a bib entry. Since I don’t find any report about this bug, is there something wrong in my use of version 4? Is there utility program that can convert bib file from version 4 to version 3.8 so that I can reuse version 3.8, which actually worked very well for me? I regret to make the switch.

Hi @Paul2017C

This is the first time I hear about such issues on Win10 and I would assume they are resolvable. Which Java version do you have installed? JabRef requires a quite new one and my guess is that your Java runtime is simply too old. You could try installing the newest version and see if it helps with JabRef.

Best regards

Thank you so much for your quick response and the solution. You are right, and the problem is due to the outdated java program on my pc. I first installed the latest version of java. But JabRef complained that it can’t locate an environment variable for java. I then reinstalled JabRef. During the reinstallation, I was asked to install java. Then the problem seems solved. Maybe JabRef could include a warning if it detects an outdated java. Anyway, JabRef 4 is now working well for me. Thanks a lot.

Good to hear your problem is solved! And thanks for the suggestion on Java version detection, we are thinking about including something like this.

Have to say that I too, have an issue that can be described in this way. I use JabRef as my digital lab-book. To do so I’ve created custom entry type with multiple fields. And some of them are blank and uneditable in Required/Optional fields tabs. Thus I have to edit Bibtex source record. Funny, but the same very fields are correctly recognized within Entry table. I’ve tried the suggested way with reinstalling JabRef without Java so that the wizard reinstalled recommended Java version, but it did not help.

Thanks in advance for your help.

If the entry editor works for normal types, then this is probably not the same problem as above. Rather, it could be a bug related to custom entry types. You should probably create an issue at and describe how we can reproduce the problem.

Yes, apparently, with my standard library everything works well. Thanks - will go to GitHub.