\Lawry\'{n}czuk does not display correctly

The name shown on the title does not render correctly in version 4.0. It is displayed only as “nczuk” (with an acute accent over the ‘n’)

Further, it is sorted as the first item in the list, which is illogical - this is an ‘L with a stroke’ - and inconsistent with the (sensible) behaviour that sorts “\u{S}progar” as a ‘S’ with diacritic.

P.

Hi,

the display is a known problem and be easily solved by selecting or installing a different font:
Under Windows you should select Dialog as Table font. For other OS check out this wiki/FAQ entry
http://help.jabref.org/en/FAQosx#q-some-characters-are-not-displayed-in-the-main-table-math-characters-or-some-upper-cased-letter

Maciej {{\L}}awry{{\'{n}}}czuk

is displayed correctly on Windows 10:

OK. Sorry - I didn’t specify my OS: Linux Mint 18.2.

Any idea which of the many built-in fonts works? Or is there any specific downloadable font that is known to work (rather than me searching randomly)?

P.

As an addition: FWIW: The “Dialog” font appears as an option… but does not work (with Linux).

P.

http://www.fileformat.info/info/unicode/block/mathematical_alphanumeric_symbols/fontsupport.htm

OK. I have done some more digging into this and, basically, it is not a font issue!

Many of the fonts listed in http://www.fileformat.info/info/unicode/block/mathematical_alphanumeric_symbols/fontsupport.htm exist in my system and none of them makes any difference. I noticed,however, that

and changing my bib file to read “{\L}awry’{n}czuk” does indeed display correctly with a number of fonts. What has thrown me here is that JabRef 3.8.2 appears to display “\Lawry’{n}czuk” correctly although on closer inspection, the ‘L’ does not have a stroke through it. FWIW: Citing as “\Lawry’{n}czuk” gives an unrecognised control error in Latex; the set of curly braces around “\L” are needed.

The upshot is that my bib file entry was incorrect but I was fooled into thinking it was OK because JabRef 3.8.2 seemed to display it correctly. The corollary is that the parser in version 4.0 now does a better job of aligning with Latex :smiley:. So, well done for the bug fix! Issue closed.

P.

1 Like

Hi,

thank you very much for the feedback! You can always enter names in Unicode and let them convert to latex via right click in the authors field -> Convert to latex… This also works vice versa

With version 4 we switched to a new latex2unicode parser which is more powerful and flexible

Regards
Christoph