Move subgroup to group

I somehow managed to make the group, ‘Aitchison geometry,’ a subgroup of AMD. How do I move it up the hierarchy so it is once again a main group heading? I’ve look on the menus and the buttons on the group window without finding a way to move it.



You can use drag & drop to reorder groups and change the hierarchy. This should also be explained in the help. If not, I would kindly ask you to add a sentence or two, so that other users can also find it. Thanks.


I’ve tried dragging the subgroup to the outside, up, and down. The cursor
turns into a circle with a diagonal slash (indicating ‘no’) and nothing
happens. And, this subgroup supposedly includes all 900+ references in the
data base and is a default keyword on new entries.

Guess I need to hand-edit the .bib file to clean this up.




As I wrote yesterday, the category refused to be dragged so it couldn’t be
dropped. However, I fixed the issue at the source.

With the .bib file open in emacs I searched for the problem category name
and replaced it in the keyfields as appropriate. Interesting to me that all
references in two major categories (fuzzy logic and environmental impact
assessment) were the only references affected. Replacing the keywords solved
this problem.

At the end of the file is the JabRef metadata. All categories but the
problem one were preceeded by the numeral 2; the problem category was
preceeded by the numberal 3. These are obviously depth references. Changing
the 3 to a 2 moved the category to its proper level.

I don’t know if this message should be added to the help at the above URL.
If so, anyone (or I) can do this.



Rich, I’m glad you found a solution! To be honest, I don’t really understand why you couldn’t change the hierarchy with drag & drop - this should work (but yes, your trick with editing the bib file directly also works). Moreover, what was exactly the problem with

If you can reproduce this bug, it would be nice if you could open an issue at github so that we can fix the underlying reason.

You have to move the selected group over the other group in the space between two groups


I’ve no idea what caused the problem. I think the reason I could not
dragon drop was described by Christopher: there was no blank space between
two entries in which to move the subgroup.

It looked something like this:


What was needed was moving the subgroup to be a group in the same
alphabetical order. There was no place to drag it.

Serendipitously, while looking at the .bib file I also I learned why the
tabs had changed from those I had previously used: JabRef thought I was
using biblatex. When I edited that line to bibtex and opened JabRef the
number of tabs returned to what I used to see. I had not before noticed the
two choices in the drop down box at the bottom of the first tab on the
Preferences menu.

So, now JabRef is again working properly for me and I’ve learned more
about using it.



1 Like