Search brings up edit mode, cursor skips out of search in to field

Jabref 3.6
Windows 10

With my database open, I type in the search field. As I type, the autocomplete box shows, but Jabref then loads an entry in edit mode, and the cursor jumps down in to one of the fields, even if my mouse cursor stays in the search field. I end up typing in one of the fields for that entry, rather than the search box (sometimes name, sometimes crossref, depends on the type of entry), which gives me all sorts of headaches.

Not sure how to proceed in terms of reproducibility or troubleshooting, and can’t see (though it may exist) what setting I might want to enable/disable.

Any suggestions or questions are welcomed.

edited for more details

I used to have the same issue on Linux with a July 3.6 snapshot. Now I have downloaded the latest development snapshot; and actually, the behaviour seems even more unclear… I will report this as a bug -

the current development version seems to have solved the issue.

Yes, thank you for the suggestion. Problem is resolved.