"The library has been modified by another program"

@evkamat I created this github issue for you: Broken Backups - possibly caused by terminating frozen JabRef · Issue #10026 · JabRef/jabref · GitHub Would be great to hear your feedback, once you tried the development version.

Thanks to the developers of JabRef!
(…gratitude is never enough for this nice free app:
long-life to open-source initiatives! : )

I still get the problem with JabRef 5.12.

My JabRef settings:
JabRef 5.12–2023-12-24–4233bad
Windows 11 10.0 amd64
Java 21.0.1
JavaFX 21.0.1+6

@GianlucaBaldassarre Please test again with 5.13 We improved this

With 5.13, after I copied the bib file to another name and then copied it back, the problem disappeared.

JabRef 5.13--2024-04-01--6bdcf63
Mac OS X 14.5 aarch64 
Java 21.0.2 
JavaFX 22+30
1 Like

Maybe a little late with this comment, but if you have a backup of the “broken” library file, you could compare the “before” and “after” file with third party tools, such as Meld. Would be nice to find out what exactly was the difference in your case.