Trying to get a pdf linked to its citation and it's going to "misc"?

Been working with Jabref for a while now, and more or less I’m getting it done as needed . . . however, I recently had a reference that was “free full text” but the linked document was covered in watermarks saying, “do not duplicate” . . . . Using >lookup > search for article online failed to find that item and link it . . . . But it wasn’t readable anyway.

I asked the school librarian to procure the pdf w/o watermarks and that worked to manually download the article. But when I tried to use >lookup > search for unlinked local files . . . I moved the document out of Downloads and into the directory and then tried to link it . . . and that showed the directory and a number of other files . . . I unchecked all of the files except the one I wanted to add to the citation listing . . . and it appeared to import them all??? but it was showing them as “misc” items imported into the general database? I found the item separate from the citation, deleted it and tried it again . . . the second time it just imported the one item, but then it showed an error, “item contains no data”???

The behavior isn’t at least consistent, so I don’t know if I need to move the file out of the database directory and back into Downloads and try again? Or if this is some kind of “bug” glitch that happens with trying to add articles manually into the database? I’m running Jabref 5.6 from 4/25/22 and see there is an update available . . . doesn’t seem like Pop_OS is handling the upgrades??? I see that 5.7 is available . . . stuff to do right now, but main question is, does any of that have anything to do with this “failure to link” the article problem?? I recall that I have done this previously w/o it being a problem . . . .

Thanks for any direction on this . . . I’m stuck . . . .

Checking through my database it appears that none of the articles that I linked to line items are showing up in the listing . . . there is just a file name location for where the article is stored, but Jabref doesn’t seem to be opening that article and showing the contents as I believe it once was?? Something changed that behavior, question is when and where did that happen???

Hello Esteelpaz,

First of all, I would ask you to update JabRef to 5.7. There have been quite a few improvements as you can see in the changelog.

Secondly, “Search for unlinked local files” will try to detect metadata automatically from linked PDFs and create entries from this metadata. There is a certain order to this and JabRef first looks for certain attached data, before it falls back to other parsing methods. One of these other methods is Grobid.

Sometimes (actually quite often) metadata cannot be parsed perfectly. It also can be the case that metadata is not attached to the PDFs at all, so the parsing will fail naturally and this might explain why you have some “misc” entries, which only contain the link to the entry.

I would suggest to change your workflow to create a separate group/library and import all unlinked files. Then go through them one by one manually and check for correctness of the metadata.

Alternatively, you could search for metadata online (or SOMEWHERE) and import or enter it into JabRef. If at the same time your PDFs on your system are named after a certain pattern, you could use Quality > Automatically set file links (F7).
In this case, linked file preferences become relevant. This is the place where you can define your linked file name patterns:


Thanks for the hints . . . I’ll look into the upgrade option. I checked apt and the Pop! store and both showed that Jabref was “up to date” . . . I’m at work right now so I don’t want to do a large download on their internet . . . I’ve upgraded Jabref a few times, but that process has slipped my mind . . . (old guy syndrome) . . . .

So, I looked in Prefs and I see that the system has that Grobid option checked . . . .

In the Linked files section I wasn’t sure if you were showing that “Use regular expression” as something that would only be done when “manually” linking from local filesystem, or something set on all of the time?? I don’t have a whole huge ton of linked articles, and for the most part the “search online” works, or seemed to work well . . . . This article was somehow sort of “masked” to prevent “duplication” . . . .

But, then, in fiddling with this one article it now appears that articles that were previously openable and readable by way of Jabref . . . are now not???

@esteelpaz You can always manually add files. Open the entry in the entry editor → General → File → There is a “+” button.

Just one question: Where is your bib file located on your computer (e…g. the path) and where do your store your pdfs? In the same folder?

Regarding updates: You can download the deb file JabRef download latest version


You don’t have to use regular expressions and you don’t have to use “automatically set file links (F7)”, if you manually link your files. Manually linking is always possible :slight_smile:

1 Like


Thanks also to you for the reply. OK, “manually add files” . . . yes, I have done that previously, of course I mostly would want to “automatically” add files or pdf’s to a reference. I was noticing in Jabref in >File there is an >import command option, as I was at work I didn’t have a chance to play with that.

But, in answer to your “where do you store your bib & pdfs” . . . yes, in the same directory/folder is where the database file and the pdfs are stored. That either carried over from my previous DB app “Bookends” or that was/is where Jabref was moving the attached pdfs?? so I just continued with that behavior. Is that the source of my error?

Thanks for the links to upgrade, if it’s a .deb file then it’s all good . . . I believe Pop! uses “eddy” to install .deb files . . . .

I haven’t had a chance to get back to Jabref just yet . . . later today might be a chance to play with it. A little bit painful to have had all of these pdfs attached to their citation and now seemingly are “detached”??


Thanks for the quick replies . . . so OK, yes, “manually” is always an option, just not the preferred option. Something about this file wasn’t allowing “search for it online and automatically attach it, etc” . . . .

I guess my question is, what should the “more or less standard” setting be for daily driving of Jabref and “automatic” attachment of the full text articles???

No proble,. Then just make sure the checkbox “Store and search files relative to library file location” is checked.

I guess my question is, what should the “more or less standard” setting be for daily driving of Jabref and “automatic” attachment of the full text articles???

JabRef is able to do this via “Search for full text online” and can do this on import as well, if you enter a new entry by DOI for example. The file will then be stored in the right directory.
But sometimes the publisher change their websites and JabRef is no longer able to find the pdfs.

Manual adding:
JabRef has cleanup actions (Quality-> Cleanup) to automatically move and rename the file to the right directory. Or just a right click in the file field.

You might want to check Quality-> “Automatically set file links” for linking the files to the entry.

1 Like