Two identical linked files, instead of one linked file. Linked files preference ignored

if I add a library, the pdf it auto finds will have two same files.
all the same. why?

More information is needed to answer your question.

More specifically:

  1. What method did you use to find pdf for your library?
  2. What were your search parameters?

My first estimate would be that if you used the method search for unlinked local files (Shift+F7) you have a duplicate of the pdf file in the folder you opted to attach from.

I let it auto find pdf file.
If I add a library, it will find two same pdf files.

Sorry, i don’t know how to reproduce your issue. More details needed.

Do you have a screenshot?

Ok good. That is something.

Would you be so nice to provide a screenshot of

  • options>preferences>linked files

Also, could you report, how many pdfs with this name are within the folder 04-AdvOthers? Is it definitely just a single pdf file?

You can check if you left-click on one of the two files within Jabref, then right-click and choose Open folder

of course, it is definitely just a single pdf file.
It would not have two same pdf file in a direction

Hmm. I have tried a few things, but i cannot reproduce the duplication on

JabRef 5.4–2021-12-20–ab44182
Windows 10 10.0 amd64
Java 16.0.2
JavaFX 17.0.1+1

When you click the link, another will show

Indeed, i was now able to reproduce by manually clicking the link.

If i click on both links i am able to attach the same file twice. Jabref somehow does not detect, that it is a duplicate.

I think it is related to this bug:

The duplication happens when you have search and store files relative to library file location activated while at the same time, the main file directory points (while being deactivated (!), which is the bug) to the same folder your bib file is located in.

The duplication vanishes and thereby your problem will be solved, if you delete the lines that are written in main file directory under options>preferences>linked files

The duplication ALSO happens, if you set the main file directory under library>library properties>Override default file directories>General file directory to the same folder your bib file is located in and search and store files relative to library file is activated.

I have no lines in the main file direction


could you solve the problem in the next version?

Have you tried restarting Jabref after deleting the lines?

there are no lines before and now